summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-19 15:47:00 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-19 15:47:00 +0000
commitc49f10e9434a6bc24b5cf7987dfce19a64852eb0 (patch)
tree7d3810a2c8fb167195e3486d8ad402e17516f152 /dev-python/irc
parentversion bump (diff)
downloadgentoo-2-c49f10e9434a6bc24b5cf7987dfce19a64852eb0.tar.gz
gentoo-2-c49f10e9434a6bc24b5cf7987dfce19a64852eb0.tar.bz2
gentoo-2-c49f10e9434a6bc24b5cf7987dfce19a64852eb0.zip
bump; Drop py3.1 support, update deps., re-add test phase which was seemingly dropped post irc-8.0, add IUSE test
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/ChangeLog8
-rw-r--r--dev-python/irc/irc-8.5.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/irc/ChangeLog b/dev-python/irc/ChangeLog
index 11b68d502e91..cb6080694cab 100644
--- a/dev-python/irc/ChangeLog
+++ b/dev-python/irc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/irc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.12 2013/08/10 13:07:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/ChangeLog,v 1.13 2013/08/19 15:47:00 idella4 Exp $
+
+*irc-8.5 (19 Aug 2013)
+
+ 19 Aug 2013; Ian Delaney <idella4@gentoo.org> +irc-8.5.ebuild:
+ bump; Drop py3.1 support, update deps., re-add test phase which was seemingly
+ dropped post irc-8.0, add IUSE test
*irc-8.4 (10 Aug 2013)
diff --git a/dev-python/irc/irc-8.5.ebuild b/dev-python/irc/irc-8.5.ebuild
new file mode 100644
index 000000000000..176fa7a42d93
--- /dev/null
+++ b/dev-python/irc/irc-8.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/irc/irc-8.5.ebuild,v 1.1 2013/08/19 15:47:00 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python."
+HOMEPAGE="https://bitbucket.org/jaraco/irc http://pypi.python.org/pypi/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="app-arch/unzip
+ app-text/dos2unix
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/hgtools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="!>=dev-python/python-irclib-3.2.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Prevent setup from downloading hgtools package
+ dos2unix setup.py || die "Failed attempt of conversion by dos2unix"
+
+ # Don't rely on hgtools for version
+ sed -e "s/use_hg_version=True/version=\"${PV}\"/" -i setup.py || die
+ sed -e "/^tag_/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test irc/tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( scripts/. )
+ distutils-r1_python_install_all
+}