summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-22 03:53:09 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-22 03:53:09 +0000
commitc34d5b867fa0677b721582b650aa6fe968e2ba64 (patch)
treec278045550a06e34104823f01d51d9bb3a3ab140 /dev-python/joblib/joblib-0.8.3.ebuild
parentFix json-c dep, add postgres-9.4 support #516986 (diff)
downloadgentoo-2-c34d5b867fa0677b721582b650aa6fe968e2ba64.tar.gz
gentoo-2-c34d5b867fa0677b721582b650aa6fe968e2ba64.tar.bz2
gentoo-2-c34d5b867fa0677b721582b650aa6fe968e2ba64.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/joblib/joblib-0.8.3.ebuild')
-rw-r--r--dev-python/joblib/joblib-0.8.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/joblib/joblib-0.8.3.ebuild b/dev-python/joblib/joblib-0.8.3.ebuild
new file mode 100644
index 000000000000..5e300e48e7d6
--- /dev/null
+++ b/dev-python/joblib/joblib-0.8.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/joblib/joblib-0.8.3.ebuild,v 1.1 2014/08/22 03:53:09 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="http://pythonhosted.org/joblib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+# Usual; req'd for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/ doc/ doc/html || die "docs failed installation"
+ fi
+}
+
+python_test() {
+ # https://github.com/joblib/joblib/issues/143
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_func_inspect_errors:_&:' -i ${PN}/test/test_func_inspect.py || die
+ sed -e 's:test_parallel_pickling:_&:' -i ${PN}/test/test_parallel.py || die
+ fi
+
+ nosetests -w ${PN}/test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}