summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2007-08-23 00:19:28 +0000
committerRobert Buchholz <rbu@gentoo.org>2007-08-23 00:19:28 +0000
commit6e2d7120d45c7aaafe04f29c008924bc0029c013 (patch)
treec6dc7c89c984bb7e79232e3fbded47944061507f /dev-python/kaa-base
parentExtending freevo deps (diff)
downloadgentoo-2-6e2d7120d45c7aaafe04f29c008924bc0029c013.tar.gz
gentoo-2-6e2d7120d45c7aaafe04f29c008924bc0029c013.tar.bz2
gentoo-2-6e2d7120d45c7aaafe04f29c008924bc0029c013.zip
Remove pynotifier files from kaa-sources and depend on dev-python/pynotifier
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-python/kaa-base')
-rw-r--r--dev-python/kaa-base/ChangeLog7
-rw-r--r--dev-python/kaa-base/files/digest-kaa-base-0.1.3-r13
-rw-r--r--dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild33
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/kaa-base/ChangeLog b/dev-python/kaa-base/ChangeLog
index c74497c1d5fc..780592910b59 100644
--- a/dev-python/kaa-base/ChangeLog
+++ b/dev-python/kaa-base/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kaa-base
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.1 2007/07/11 23:40:23 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/ChangeLog,v 1.2 2007/08/23 00:19:28 rbu Exp $
+
+*kaa-base-0.1.3-r1 (23 Aug 2007)
+
+ 23 Aug 2007; Robert Buchholz <rbu@gentoo.org> +kaa-base-0.1.3-r1.ebuild:
+ Remove pynotifier files from kaa-sources and depend on dev-python/pynotifier
*kaa-base-0.1.3 (11 Jul 2007)
diff --git a/dev-python/kaa-base/files/digest-kaa-base-0.1.3-r1 b/dev-python/kaa-base/files/digest-kaa-base-0.1.3-r1
new file mode 100644
index 000000000000..2fc66d5d51af
--- /dev/null
+++ b/dev-python/kaa-base/files/digest-kaa-base-0.1.3-r1
@@ -0,0 +1,3 @@
+MD5 d9318e34148275cfd30bcfe2360bb28b kaa-base-0.1.3.tar.gz 122141
+RMD160 898f4a7b0c10c6cda3289fd7721dc7dff02048ea kaa-base-0.1.3.tar.gz 122141
+SHA256 97d43e82bc52013bfcd46370118211475a9edd88a8c5d90abf71464bd4f3572f kaa-base-0.1.3.tar.gz 122141
diff --git a/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild b/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..b25581f5ee9e
--- /dev/null
+++ b/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kaa-base/kaa-base-0.1.3-r1.ebuild,v 1.1 2007/08/23 00:19:28 rbu Exp $
+
+inherit python eutils distutils
+
+DESCRIPTION="Basic Framework for all Kaa Python Modules."
+HOMEPAGE="http://freevo.sourceforge.net/kaa/"
+SRC_URI="mirror://sourceforge/freevo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="sqlite lirc"
+
+RDEPEND="dev-libs/libxml2
+ dev-python/pynotifier
+ sqlite? ( >=dev-libs/glib-2.4.0 >=dev-python/pysqlite-2.2 )
+ lirc? ( dev-python/pylirc )"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ rm -rf src/notifier/pynotifier
+}
+
+pkg_setup() {
+ if !(built_with_use dev-libs/libxml2 python); then
+ eerror "dev-libs/libxml2 must be built with the 'python' USE flag"
+ die "Recompile dev-libs/libxml2 with the 'python' USE flag enabled"
+ fi
+}