summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-23 05:22:25 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-23 05:22:25 +0000
commit9041ef8a5c6aa88e371444776f23be2d335c2078 (patch)
tree048bc6cebbbb7610a826ed7f27114c270cbcaa50 /dev-python/keyring
parentVersion bump. (diff)
downloadgentoo-2-9041ef8a5c6aa88e371444776f23be2d335c2078.tar.gz
gentoo-2-9041ef8a5c6aa88e371444776f23be2d335c2078.tar.bz2
gentoo-2-9041ef8a5c6aa88e371444776f23be2d335c2078.zip
update of dev-python/keyring to 3.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/ChangeLog7
-rw-r--r--dev-python/keyring/keyring-3.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/keyring/ChangeLog b/dev-python/keyring/ChangeLog
index cbd2228ac6c3..9bbd2883a587 100644
--- a/dev-python/keyring/ChangeLog
+++ b/dev-python/keyring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/keyring
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.9 2013/09/27 02:15:22 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/ChangeLog,v 1.10 2013/10/23 05:22:25 prometheanfire Exp $
+
+*keyring-3.1 (23 Oct 2013)
+
+ 23 Oct 2013; Matthew Thode <prometheanfire@gentoo.org> +keyring-3.1.ebuild:
+ update of dev-python/keyring to 3.1
27 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> keyring-1.5-r1.ebuild:
fix for bug 485384
diff --git a/dev-python/keyring/keyring-3.1.ebuild b/dev-python/keyring/keyring-3.1.ebuild
new file mode 100644
index 000000000000..3707da143b4d
--- /dev/null
+++ b/dev-python/keyring/keyring-3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-3.1.ebuild,v 1.1 2013/10/23 05:22:25 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} python{3_2,3_3} pypy2_0 )
+#tests restricted due to unpackaged dependancies
+RESTRICT="test"
+
+inherit distutils-r1
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
+SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+)
+# "${FILESDIR}/setup-1.0.patch"
+
+python_test() {
+ # test_backend.py and test_core.py access keyring backends
+ # which may spawn password prompts and do other damage.
+
+ # XXX: leave out the harmless tests (dummy backends?)
+
+ for t in test_{cli,util}.py; do
+ "${PYTHON}" "${BUILD_DIR}"/lib/${PN}/tests/${t} \
+ || die "${t} fails with ${EPYTHON}"
+ done
+}