summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 10:47:03 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 10:47:03 +0000
commit2c64c6e0c3db7c5eb9c36a2648168c9c1135bcd7 (patch)
tree03bc2defa0811581c96176739c371392a885cf70 /dev-python/kiwi
parentVersion bump. (diff)
downloadgentoo-2-2c64c6e0c3db7c5eb9c36a2648168c9c1135bcd7.tar.gz
gentoo-2-2c64c6e0c3db7c5eb9c36a2648168c9c1135bcd7.tar.bz2
gentoo-2-2c64c6e0c3db7c5eb9c36a2648168c9c1135bcd7.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64)
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/ChangeLog7
-rw-r--r--dev-python/kiwi/kiwi-1.9.22.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 6accfd6ecab5..6f54d55f971c 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kiwi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.10 2008/03/28 06:58:26 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.11 2008/06/25 10:47:03 hawking Exp $
+
+*kiwi-1.9.22 (25 Jun 2008)
+
+ 25 Jun 2008; Ali Polatel <hawking@gentoo.org> +kiwi-1.9.22.ebuild:
+ Version bump.
*kiwi-1.9.21 (28 Mar 2008)
diff --git a/dev-python/kiwi/kiwi-1.9.22.ebuild b/dev-python/kiwi/kiwi-1.9.22.ebuild
new file mode 100644
index 000000000000..441b76f2c357
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.22.ebuild,v 1.1 2008/06/25 10:47:03 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils versionator
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/"
+SRC_URI="http://download.gnome.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/pygtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:share/doc/kiwi:share/doc/${PF}:g" \
+ setup.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}