summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-26 14:25:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-26 14:25:35 +0000
commit48e033fd4eef5048ddaf23a94e2400a9db90e5c1 (patch)
tree431baf4acd1d35f0c3d7f80f917ce2b6c8f1c9bd /dev-python/kiwi
parentDelete older ebuild. (diff)
downloadgentoo-2-48e033fd4eef5048ddaf23a94e2400a9db90e5c1.tar.gz
gentoo-2-48e033fd4eef5048ddaf23a94e2400a9db90e5c1.tar.bz2
gentoo-2-48e033fd4eef5048ddaf23a94e2400a9db90e5c1.zip
Fix dependencies.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/kiwi-1.9.26.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/dev-python/kiwi/kiwi-1.9.26.ebuild b/dev-python/kiwi/kiwi-1.9.26.ebuild
index c3f192f975e4..39f50bd1aac0 100644
--- a/dev-python/kiwi/kiwi-1.9.26.ebuild
+++ b/dev-python/kiwi/kiwi-1.9.26.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.26.ebuild,v 1.2 2009/10/10 17:26:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.26.ebuild,v 1.3 2010/05/26 14:25:35 arfrever Exp $
-NEED_PYTHON="2.3"
+EAPI="3"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils versionator
@@ -18,21 +19,17 @@ IUSE="examples"
DEPEND="dev-python/pygtk"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
-RESTRICT_PYTHON_ABIS="3*"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "s:share/doc/kiwi:share/doc/${PF}:g" \
- setup.py || die "sed failed"
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
}
src_install() {
distutils_src_install
- if use examples ; then
+ if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi