summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 09:44:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 09:44:30 +0000
commitef23c32540898931fc567d4511f544b8af1cf871 (patch)
tree6660dd2f0dbf10ddf4ad2e42dceaaaa925a04f93 /dev-python/kiwi
parentRevision bump (diff)
downloadgentoo-2-ef23c32540898931fc567d4511f544b8af1cf871.tar.gz
gentoo-2-ef23c32540898931fc567d4511f544b8af1cf871.tar.bz2
gentoo-2-ef23c32540898931fc567d4511f544b8af1cf871.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/kiwi')
-rw-r--r--dev-python/kiwi/ChangeLog8
-rw-r--r--dev-python/kiwi/kiwi-1.9.35.ebuild59
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 8c46757e247d..e070f877bc9b 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/kiwi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.17 2012/05/20 00:37:11 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.18 2012/10/09 09:44:30 patrick Exp $
+
+*kiwi-1.9.35 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +kiwi-1.9.35.ebuild:
+ Bump
20 May 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml:
Add remote-id.
@@ -78,4 +83,3 @@
19 Oct 2006; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+kiwi-1.9.11.ebuild:
Initial commit. Thank you Jason Pepas <j.pepas@mail.utexas.edu> bug# 137441
-
diff --git a/dev-python/kiwi/kiwi-1.9.35.ebuild b/dev-python/kiwi/kiwi-1.9.35.ebuild
new file mode 100644
index 000000000000..ed6525efd61b
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.35.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.35.ebuild,v 1.1 2012/10/09 09:44:30 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython *-pypy-*"
+
+inherit distutils versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="dev-python/pygtk"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pep8
+ dev-python/pyflakes
+ dev-python/twisted
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ # Tarballs are missing files.
+ # https://code.launchpad.net/~floppym/kiwi/testfiles/+merge/106505
+ rm tests/test_ui.py tests/test_Delegate.py
+
+ testing() {
+ "$(PYTHON)" tests/run_all_tests.py
+ }
+ VIRTUALX_COMMAND=python_execute_function virtualmake testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}