summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-03-07 11:31:02 +0000
committerJustin Lecher <jlec@gentoo.org>2014-03-07 11:31:02 +0000
commit68b361cb43401dd7347353912c43c06fbc57c3d7 (patch)
tree3f930aebc642be78c938f840094280ad6f97ab12 /dev-python/lxml
parentRevision bump. Support udev eclass to fix up udev rules.d path. (diff)
downloadgentoo-2-68b361cb43401dd7347353912c43c06fbc57c3d7.tar.gz
gentoo-2-68b361cb43401dd7347353912c43c06fbc57c3d7.tar.bz2
gentoo-2-68b361cb43401dd7347353912c43c06fbc57c3d7.zip
dev-python/lxml: Version Bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/ChangeLog8
-rw-r--r--dev-python/lxml/lxml-3.3.3.ebuild71
-rw-r--r--dev-python/lxml/metadata.xml8
3 files changed, 82 insertions, 5 deletions
diff --git a/dev-python/lxml/ChangeLog b/dev-python/lxml/ChangeLog
index 4004a3d6a5eb..b2552481fed2 100644
--- a/dev-python/lxml/ChangeLog
+++ b/dev-python/lxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/lxml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.186 2014/03/05 15:37:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.187 2014/03/07 11:31:02 jlec Exp $
+
+*lxml-3.3.3 (07 Mar 2014)
+
+ 07 Mar 2014; Justin Lecher <jlec@gentoo.org> +lxml-3.3.3.ebuild,
+ metadata.xml:
+ Version Bump
05 Mar 2014; Agostino Sarubbo <ago@gentoo.org> lxml-3.3.0.ebuild:
Stable for ppc, wrt bug #500684
diff --git a/dev-python/lxml/lxml-3.3.3.ebuild b/dev-python/lxml/lxml-3.3.3.ebuild
new file mode 100644
index 000000000000..9bbd08312dfc
--- /dev/null
+++ b/dev-python/lxml/lxml-3.3.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.3.3.ebuild,v 1.1 2014/03/07 11:31:02 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
+HOMEPAGE="http://lxml.de/ http://pypi.python.org/pypi/lxml/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD ElementTree GPL-2 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="beautifulsoup3 doc examples +threads"
+
+# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
+RDEPEND="
+ >=dev-libs/libxml2-2.7.2
+ >=dev-libs/libxslt-1.1.15
+ beautifulsoup3? (
+ python_targets_python2_6? ( dev-python/beautifulsoup:python-2[python_targets_python2_6] )
+ python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
+ python_targets_python3_2? ( dev-python/beautifulsoup:python-3[python_targets_python3_2] )
+ python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# lxml tarball contains files pregenerated by Cython.
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # avoid replacing PYTHONPATH in tests.
+ sed -i -e '/sys\.path/d' test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
+ cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
+ ln -s "${S}"/doc "${BUILD_DIR}"/ || die
+
+ local test
+ for test in test.py selftest.py selftest2.py; do
+ einfo "Running ${test}"
+ "${PYTHON}" ${test} || die "Test ${test} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ if use doc; then
+ local DOCS=( *.txt doc/*.txt )
+ local HTML_DOCS=( doc/html/. )
+ fi
+ use examples && local EXAMPLES=( samples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/lxml/metadata.xml b/dev-python/lxml/metadata.xml
index 76cfdbee32d4..ed9a2f8c7db2 100644
--- a/dev-python/lxml/metadata.xml
+++ b/dev-python/lxml/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
- <use>
- <flag name='beautifulsoup3'>Enable support for Beautiful Soup 3</flag>
- </use>
+ <herd>python</herd>
+ <use>
+ <flag name="beautifulsoup3">Enable support for Beautiful Soup 3</flag>
+ </use>
</pkgmetadata>