summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-12 15:48:32 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-12 15:48:32 +0000
commitb96224a1199c83f529d3ac051ebc602648ca61bd (patch)
tree116110cb3a12a544fcb3274675ace3bb68af503e /dev-python/meld3/meld3-1.0.0.ebuild
parentdrop py2.6 pypy2_0 add py3.4 support (diff)
downloadgentoo-2-b96224a1199c83f529d3ac051ebc602648ca61bd.tar.gz
gentoo-2-b96224a1199c83f529d3ac051ebc602648ca61bd.tar.bz2
gentoo-2-b96224a1199c83f529d3ac051ebc602648ca61bd.zip
bump; drop pypy2_0 py2.6 add py3 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/meld3/meld3-1.0.0.ebuild')
-rw-r--r--dev-python/meld3/meld3-1.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/meld3/meld3-1.0.0.ebuild b/dev-python/meld3/meld3-1.0.0.ebuild
new file mode 100644
index 000000000000..16c714aabddb
--- /dev/null
+++ b/dev-python/meld3/meld3-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/meld3/meld3-1.0.0.ebuild,v 1.1 2014/05/12 15:48:32 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine."
+HOMEPAGE="https://github.com/supervisor/meld3 http://pypi.python.org/pypi/meld3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# tests use a local path.
+RESTRICT=test
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" ${PN}/test_${PN}.py || die "Tests failed under ${EPYTHON}"
+}