summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-26 10:00:09 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-26 10:00:09 +0000
commitea756b3e66f3293556564c674640ea6bb4c430df (patch)
tree000477d3f596a36be803da9a073e2db6b91c993f /dev-python/mpi4py
parentVersion bump (diff)
downloadgentoo-2-ea756b3e66f3293556564c674640ea6bb4c430df.tar.gz
gentoo-2-ea756b3e66f3293556564c674640ea6bb4c430df.tar.bz2
gentoo-2-ea756b3e66f3293556564c674640ea6bb4c430df.zip
migrate to distutils-r1, keep old for now considering changes needed
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/ChangeLog7
-rw-r--r--dev-python/mpi4py/mpi4py-1.3-r1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/mpi4py/ChangeLog b/dev-python/mpi4py/ChangeLog
index ea3b2bfac734..1e6a9e0e3bfb 100644
--- a/dev-python/mpi4py/ChangeLog
+++ b/dev-python/mpi4py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mpi4py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.10 2013/07/01 23:09:47 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.11 2013/07/26 10:00:09 idella4 Exp $
+
+*mpi4py-1.3-r1 (26 Jul 2013)
+
+ 26 Jul 2013; Ian Delaney <idella4@gentoo.org> +mpi4py-1.3-r1.ebuild:
+ migrate to distutils-r1, keep old for now considering changes needed
01 Jul 2013; Julian Ospald <hasufell@gentoo.org> mpi4py-1.3.ebuild:
fix sandbox issues similar to bug #462602
diff --git a/dev-python/mpi4py/mpi4py-1.3-r1.ebuild b/dev-python/mpi4py/mpi4py-1.3-r1.ebuild
new file mode 100644
index 000000000000..3b0bb722d5eb
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-1.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3-r1.ebuild,v 1.1 2013/07/26 10:00:09 idella4 Exp $
+
+EAPI=5
+# README.txt excludes 3.3, absent tox.ini includes 3.3, tests fail py3.3
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ virtual/mpi[romio] )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # not needed on install
+ rm -r docs/source || die
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ export FAKEROOTKEY=1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ echo "Beginning test phase"
+ pushd "${BUILD_DIR}"/../ &> /dev/null
+ mpiexec -n 2 "${PYTHON}" ./test/runtests.py || die "Testsuite failed under ${EPYTHON}"
+ popd &> /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}