summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-01-11 13:04:18 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-01-11 13:04:18 +0000
commit3d50e97d6b14c92d7f7883fd5e1e02b56b58fb7b (patch)
tree7c2abd185fc278f9414dc76544a64070000b142e /dev-python/mpmath
parentStable for HPPA (bug #497738). (diff)
downloadgentoo-2-3d50e97d6b14c92d7f7883fd5e1e02b56b58fb7b.tar.gz
gentoo-2-3d50e97d6b14c92d7f7883fd5e1e02b56b58fb7b.tar.bz2
gentoo-2-3d50e97d6b14c92d7f7883fd5e1e02b56b58fb7b.zip
Version bump
(Portage version: 2.2.8/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/ChangeLog9
-rw-r--r--dev-python/mpmath/mpmath-0.18.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index 0aadc8f9f0b9..7d508cecf348 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mpmath
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.28 2013/10/13 08:45:45 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.29 2014/01/11 13:04:18 grozin Exp $
+
+*mpmath-0.18 (11 Jan 2014)
+
+ 11 Jan 2014; Andrey Grozin <grozin@gentoo.org> +mpmath-0.18.ebuild:
+ Version bump
13 Oct 2013; Pacho Ramos <pacho@gentoo.org> mpmath-0.17-r1.ebuild:
Also compatible with python3_3
diff --git a/dev-python/mpmath/mpmath-0.18.ebuild b/dev-python/mpmath/mpmath-0.18.ebuild
new file mode 100644
index 000000000000..55b641abbc5e
--- /dev/null
+++ b/dev-python/mpmath/mpmath-0.18.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.18.ebuild,v 1.1 2014/01/11 13:04:18 grozin Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 eutils # virtualx
+
+MY_PN=${PN}-all
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath/"
+SRC_URI="mirror://pypi/m/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
+IUSE="doc examples gmp matplotlib test"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy )
+ matplotlib? ( dev-python/matplotlib )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}.patch"
+ )
+
+ # this fails with the current version of dev-python/py
+ rm -f ${PN}/conftest.py || die
+
+ # this test requires X
+ rm -f ${PN}/tests/test_visualization.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ cd doc || die
+ "${PYTHON}" build.py || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ py.test -v || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/. )
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*
+ fi
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install
+ local path="${ED}$(python_get_sitedir)/${PN}/libmp/"
+ if [[ "${EPYTHON}" != python2* ]]; then
+ rm -f "${path}exec_py2.py" || ide
+ elif [[ "${EPYTHON}" != python3 ]]; then
+ rm -f "${path}exec_py3.py" || die
+ fi
+}