summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-24 18:30:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-24 18:30:06 +0000
commit5695236dbc9aa3a6b99dc272c022121e56b54bee (patch)
tree1b653d6b7ff15720ac2d96b81527f6e20df1531e /dev-python/mpmath
parentDelete older ebuild. (diff)
downloadgentoo-2-5695236dbc9aa3a6b99dc272c022121e56b54bee.tar.gz
gentoo-2-5695236dbc9aa3a6b99dc272c022121e56b54bee.tar.bz2
gentoo-2-5695236dbc9aa3a6b99dc272c022121e56b54bee.zip
Version bump.
(Portage version: 2.2_rc86_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/ChangeLog8
-rw-r--r--dev-python/mpmath/mpmath-0.16.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index bb3b8312c50e..01406aab0e12 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.12 2010/06/07 16:47:26 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.13 2010/09/24 18:30:06 arfrever Exp $
+
+*mpmath-0.16 (24 Sep 2010)
+
+ 24 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -mpmath-0.14.ebuild, +mpmath-0.16.ebuild:
+ Version bump.
*mpmath-0.15 (07 Jun 2010)
diff --git a/dev-python/mpmath/mpmath-0.16.ebuild b/dev-python/mpmath/mpmath-0.16.ebuild
new file mode 100644
index 000000000000..00bd66bc2b3a
--- /dev/null
+++ b/dev-python/mpmath/mpmath-0.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.16.ebuild,v 1.1 2010/09/24 18:30:06 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath"
+SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz
+ doc? ( http://mpmath.googlecode.com/files/${PN}-docsrc-${PV}.tar.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gmp"
+
+RDEPEND="gmp? ( dev-python/gmpy )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+DOCS="CHANGES"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd "${WORKDIR}/doc" > /dev/null
+ PYTHONPATH="${S}/build-$(PYTHON -f --ABI)/lib" "$(PYTHON -f)" build.py || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ cd mpmath/tests
+ distutils_src_test
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd "${WORKDIR}/doc" > /dev/null
+ dohtml -r build/* || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${WORKDIR}/demo/"*
+ fi
+}