summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-10-05 12:23:55 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-10-05 12:23:55 +0000
commitfcdbcde1ec4f4521d56b2aa795d07d6111e0b61b (patch)
treefe56d1c2bf917928be883676d8cd1ebc4f42174d /dev-python/nose
parentVersion bump markdown2 to 2.1.0. (diff)
downloadgentoo-2-fcdbcde1ec4f4521d56b2aa795d07d6111e0b61b.tar.gz
gentoo-2-fcdbcde1ec4f4521d56b2aa795d07d6111e0b61b.tar.bz2
gentoo-2-fcdbcde1ec4f4521d56b2aa795d07d6111e0b61b.zip
Remove old versions of nose.
(Portage version: 2.1.11.23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog7
-rw-r--r--dev-python/nose/files/nose-0.10.0-tests-nonetwork.patch34
-rw-r--r--dev-python/nose/nose-1.0.0.ebuild73
-rw-r--r--dev-python/nose/nose-1.1.1.ebuild72
4 files changed, 6 insertions, 180 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 3b0320635a4e..4ec8aea4f294 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.84 2012/05/09 00:06:38 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.85 2012/10/05 12:23:54 djc Exp $
+
+ 05 Oct 2012; Dirkjan Ochtman <djc@gentoo.org>
+ -files/nose-0.10.0-tests-nonetwork.patch, -nose-1.0.0.ebuild,
+ -nose-1.1.1.ebuild:
+ Remove old versions.
09 May 2012; Alexis Ballier <aballier@gentoo.org> nose-1.1.2.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-python/nose/files/nose-0.10.0-tests-nonetwork.patch b/dev-python/nose/files/nose-0.10.0-tests-nonetwork.patch
deleted file mode 100644
index 6b38c5867bb7..000000000000
--- a/dev-python/nose/files/nose-0.10.0-tests-nonetwork.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- unit_tests/test_twisted.py.orig 2007-05-10 19:11:17.000000000 +0300
-+++ unit_tests/test_twisted.py 2007-10-11 09:23:05.000000000 +0300
-@@ -13,31 +13,6 @@
- class CustomError(Exception):
- pass
-
--# FIXME move all dns-using tests to functional
--
--# Should succeed unless google is down
--#@deferred
--def test_resolve():
-- return reactor.resolve("www.google.com")
--test_resolve = deferred()(test_resolve)
--
--# Raises TypeError because the function does not return a Deferred
--#@raises(TypeError)
--#@deferred()
--def test_raises_bad_return():
-- print reactor
-- reactor.resolve("nose.python-hosting.com")
--test_raises_bad_return = raises(TypeError)(deferred()(test_raises_bad_return))
--
--# Check we propagate twisted Failures as Exceptions
--# (XXX this test might take some time: find something better?)
--#@raises(DNSLookupError)
--#@deferred()
--def test_raises_twisted_error():
-- return reactor.resolve("x.y.z")
--test_raises_twisted_error = raises(DNSLookupError)(
-- deferred()(test_raises_twisted_error))
--
- # Check we detect Exceptions inside the callback chain
- #@raises(CustomError)
- #@deferred(timeout=1.0)
diff --git a/dev-python/nose/nose-1.0.0.ebuild b/dev-python/nose/nose-1.0.0.ebuild
deleted file mode 100644
index eb81126e947d..000000000000
--- a/dev-python/nose/nose-1.0.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.0.0.ebuild,v 1.10 2011/04/02 16:21:33 armin76 Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/ http://code.google.com/p/python-nose/ http://pypi.python.org/pypi/nose https://bitbucket.org/jpellerin/nose/"
-SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted )"
-
-DOCS="AUTHORS"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable tests and doc features that access the network
- epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
-
- # Disable versioning of nosetests script to avoid collision with versioning performed by distutils_src_install().
- sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" -i setup.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd doc
- mkdir -p .build/html .build/doctrees
- sphinx-build . html || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- testing() {
- if [[ "${PYTHON_ABI}" == 3.* ]]; then
- rm -fr build || return 1
- "$(PYTHON)" setup.py build_tests || return 1
- fi
-
- "$(PYTHON)" selftest.py -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install --install-data "${EPREFIX}/usr/share"
-
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/nosetests"
-
- if use doc; then
- dohtml -r -A txt doc/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/nose/nose-1.1.1.ebuild b/dev-python/nose/nose-1.1.1.ebuild
deleted file mode 100644
index fb6fcc3323fb..000000000000
--- a/dev-python/nose/nose-1.1.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.1.1.ebuild,v 1.2 2011/08/18 15:46:27 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )
- test? ( dev-python/twisted )"
-
-DOCS="AUTHORS"
-
-src_prepare() {
- distutils_src_prepare
- # Disable sphinx.ext.intersphinx, requires network
- epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
- # Disable tests requiring network connection.
- sed \
- -e "s/test_resolve/_&/g" \
- -e "s/test_raises_bad_return/_&/g" \
- -e "s/test_raises_twisted_error/_&/g" \
- -i unit_tests/test_twisted.py || die "sed failed"
- # Disable versioning of nosetests script to avoid collision with versioning performed by distutils_src_install().
- sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" -i setup.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- einfo "Generation of documentation"
- pushd doc > /dev/null
- emake html
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- if [[ "$(python_get_version --major)" == "3" ]]; then
- rm -fr build || return 1
- "$(PYTHON)" setup.py build_tests || return 1
- fi
- "$(PYTHON)" setup.py egg_info || return 1
- "$(PYTHON)" selftest.py -v
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install --install-data "${EPREFIX}/usr/share"
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/nosetests"
- if use doc; then
- dohtml -r -A txt doc/.build/html/* || die "Installation of documentation failed"
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}