summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-12-15 02:29:04 +0000
committerMike Gilbert <floppym@gentoo.org>2011-12-15 02:29:04 +0000
commited3b1fa1071d9c65a027542655c611edd2799c0b (patch)
treec750def6918bf84b34fab9aeb87d8934ebebc60a /dev-python/odfpy/odfpy-0.9.4.ebuild
parentRestore the Delete keyboard shortcut for deleting files (bug #393663, thanks ... (diff)
downloadgentoo-2-ed3b1fa1071d9c65a027542655c611edd2799c0b.tar.gz
gentoo-2-ed3b1fa1071d9c65a027542655c611edd2799c0b.tar.bz2
gentoo-2-ed3b1fa1071d9c65a027542655c611edd2799c0b.zip
Version bump based on work by Arfrever in Progress overlay. Resolves bug 389631 by Ian Delaney.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/odfpy/odfpy-0.9.4.ebuild')
-rw-r--r--dev-python/odfpy/odfpy-0.9.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/odfpy/odfpy-0.9.4.ebuild b/dev-python/odfpy/odfpy-0.9.4.ebuild
new file mode 100644
index 000000000000..79588908dc90
--- /dev/null
+++ b/dev-python/odfpy/odfpy-0.9.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/odfpy-0.9.4.ebuild,v 1.1 2011/12/15 02:29:01 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://joinup.ec.europa.eu/software/odfpy/home http://pypi.python.org/pypi/odfpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="odf"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-tests.patch"
+}
+
+src_test() {
+ testing() {
+ pushd tests > /dev/null || die
+ local exit_status=0 test
+ for test in test*.py; do
+ einfo "Running ${test} ..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}"
+ [[ $? -ne 0 ]] && exit_status=1
+ done
+ popd > /dev/null || die
+ return ${exit_status}
+ }
+ python_execute_function testing
+}