summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-21 09:06:06 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-21 09:06:06 +0000
commit73006b8f7fa468ffe7b81a702adcdc14aa992554 (patch)
tree0c7aca9565466209555b43ed7c2a1023c4364829 /dev-python/pastedeploy
parentRemove old. (diff)
downloadgentoo-2-73006b8f7fa468ffe7b81a702adcdc14aa992554.tar.gz
gentoo-2-73006b8f7fa468ffe7b81a702adcdc14aa992554.tar.bz2
gentoo-2-73006b8f7fa468ffe7b81a702adcdc14aa992554.zip
rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/ChangeLog6
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.3.3.ebuild59
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.0-r1.ebuild33
3 files changed, 5 insertions, 93 deletions
diff --git a/dev-python/pastedeploy/ChangeLog b/dev-python/pastedeploy/ChangeLog
index 8782db5bf28d..dede2397f298 100644
--- a/dev-python/pastedeploy/ChangeLog
+++ b/dev-python/pastedeploy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pastedeploy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.26 2014/12/09 08:30:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/ChangeLog,v 1.27 2014/12/21 09:06:06 idella4 Exp $
+
+ 21 Dec 2014; Ian Delaney <idella4@gentoo.org> -pastedeploy-1.3.3.ebuild,
+ -pastedeploy-1.5.0-r1.ebuild:
+ rm old
09 Dec 2014; Jeroen Roovers <jer@gentoo.org> pastedeploy-1.5.2.ebuild:
Stable for HPPA (bug #531124).
diff --git a/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild b/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild
deleted file mode 100644
index 2a26c91a0b6a..000000000000
--- a/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.3.3.ebuild,v 1.10 2014/10/15 23:10:16 blueness Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit eutils distutils multilib
-
-MY_PN="PasteDeploy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Load, configure, and compose WSGI applications and servers"
-HOMEPAGE="http://pythonpaste.org/deploy/ http://pypi.python.org/pypi/PasteDeploy"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/paste
- dev-python/setuptools"
-DEPEND="${RDEPEND}
- doc? ( dev-python/pygments dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="paste/deploy"
-
-src_prepare() {
- distutils_src_prepare
-
- # Delete broken test.
- rm -f tests/test_config_middleware.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd build/sphinx/html > /dev/null
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.0-r1.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.0-r1.ebuild
deleted file mode 100644
index 303f673d78ed..000000000000
--- a/dev-python/pastedeploy/pastedeploy-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastedeploy/pastedeploy-1.5.0-r1.ebuild,v 1.3 2014/10/15 23:10:16 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="PasteDeploy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Load, configure, and compose WSGI applications and servers"
-HOMEPAGE="http://pythonpaste.org/deploy/ http://pypi.python.org/pypi/PasteDeploy"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc"
-
-RDEPEND="dev-python/paste[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use doc && dodoc docs/*.txt
-}