summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-14 23:21:07 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-14 23:21:07 +0000
commit8e7abb1c12c2c6aac9304a3cb67c60056fed0ee3 (patch)
treece9f4ee89b7d41b853d6be20bd80082c4443d2ac /dev-python/peewee
parentEnable multilib support, bug #505004. (diff)
downloadgentoo-2-8e7abb1c12c2c6aac9304a3cb67c60056fed0ee3.tar.gz
gentoo-2-8e7abb1c12c2c6aac9304a3cb67c60056fed0ee3.tar.bz2
gentoo-2-8e7abb1c12c2c6aac9304a3cb67c60056fed0ee3.zip
bumpity bump, add IUSE examples, cleanup
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.1.6.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 1b1f433fdf72..b97a2db180eb 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.4 2014/05/09 06:07:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.5 2014/05/14 23:21:07 idella4 Exp $
+
+*peewee-2.1.6 (14 May 2014)
+
+ 14 May 2014; Ian Delaney <idella4@gentoo.org> +peewee-2.1.6.ebuild:
+ bumpity bump, add IUSE examples, cleanup
*peewee-2.1.5 (09 May 2014)
diff --git a/dev-python/peewee/peewee-2.1.6.ebuild b/dev-python/peewee/peewee-2.1.6.ebuild
new file mode 100644
index 000000000000..6c18fbbf0883
--- /dev/null
+++ b/dev-python/peewee/peewee-2.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.1.6.ebuild,v 1.1 2014/05/14 23:21:07 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}