summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-26 07:11:15 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-26 07:11:15 +0000
commita2274f92efd0151eb46f1aa4090bca73622d32d8 (patch)
tree41e0cc444fddb3e9f1a20fe36eabebd6ed04909b /dev-python/pexpect
parentRename FILE_SUFFIX to README_GENTOO_SUFFIX in order to avoid variable clashes (diff)
downloadgentoo-2-a2274f92efd0151eb46f1aa4090bca73622d32d8.tar.gz
gentoo-2-a2274f92efd0151eb46f1aa4090bca73622d32d8.tar.bz2
gentoo-2-a2274f92efd0151eb46f1aa4090bca73622d32d8.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/ChangeLog7
-rw-r--r--dev-python/pexpect/pexpect-3.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pexpect/ChangeLog b/dev-python/pexpect/ChangeLog
index 4720f934d861..3e519eb3a870 100644
--- a/dev-python/pexpect/ChangeLog
+++ b/dev-python/pexpect/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pexpect
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.68 2014/04/15 04:58:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/ChangeLog,v 1.69 2014/06/26 07:11:15 radhermit Exp $
+
+*pexpect-3.3 (26 Jun 2014)
+
+ 26 Jun 2014; Tim Harder <radhermit@gentoo.org> +pexpect-3.3.ebuild:
+ Version bump.
*pexpect-3.2 (15 Apr 2014)
diff --git a/dev-python/pexpect/pexpect-3.3.ebuild b/dev-python/pexpect/pexpect-3.3.ebuild
new file mode 100644
index 000000000000..f307fe3257d3
--- /dev/null
+++ b/dev-python/pexpect/pexpect-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pexpect/pexpect-3.3.ebuild,v 1.1 2014/06/26 07:11:15 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="http://pexpect.sourceforge.net/ http://pypi.python.org/pypi/pexpect/ https://github.com/pexpect/pexpect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-fbsd ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}