summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-20 05:44:45 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-20 05:44:45 +0000
commiteecdda36e6bc0eaf740a3c3f031df5d2408ac007 (patch)
tree8ee17993802f487161222701d8aedb6df6bc7c3e /dev-python/pip
parentVersion bump. (diff)
downloadgentoo-2-eecdda36e6bc0eaf740a3c3f031df5d2408ac007.tar.gz
gentoo-2-eecdda36e6bc0eaf740a3c3f031df5d2408ac007.tar.bz2
gentoo-2-eecdda36e6bc0eaf740a3c3f031df5d2408ac007.zip
Version bump.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-1.0.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index 913f0b46de80..f4cd28a519e0 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.1 2011/05/31 11:45:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.2 2011/07/20 05:44:45 radhermit Exp $
+
+*pip-1.0.2 (20 Jul 2011)
+
+ 20 Jul 2011; Tim Harder <radhermit@gentoo.org> +pip-1.0.2.ebuild:
+ Version bump.
*pip-1.0.1 (31 May 2011)
diff --git a/dev-python/pip/pip-1.0.2.ebuild b/dev-python/pip/pip-1.0.2.ebuild
new file mode 100644
index 000000000000..c2f7afdbbaca
--- /dev/null
+++ b/dev-python/pip/pip-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.0.2.ebuild,v 1.1 2011/07/20 05:44:45 radhermit Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit bash-completion distutils eutils
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="bash-completion zsh-completion"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}"
+
+# Tests require a couple libraries not yet in the tree, aren't bundled with
+# the default tarball from pypi, and have a couple failures anyway
+RESTRICT="test"
+
+DOCS="AUTHORS.txt docs/configuration.txt docs/how-to-contribute.txt
+ docs/index.txt docs/news.txt docs/requirement-format.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-unversioned.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ COMPLETION="${T}/completion.tmp"
+
+ if use bash-completion ; then
+ "$(PYTHON -f)" pip/runner.py completion --bash > "${COMPLETION}" || die
+ dobashcompletion "${COMPLETION}" ${PN}
+ fi
+
+ if use zsh-completion ; then
+ "$(PYTHON -f)" pip/runner.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip || die
+ fi
+}