summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2012-04-27 12:49:29 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2012-04-27 12:49:29 +0000
commit878e390465b17cec9dee123423bd3d01e46d0844 (patch)
treee64622e0fb7eec3812d636835ada67a79b5e9371 /dev-python/pkginfo
parentRemove old version. (diff)
downloadgentoo-2-878e390465b17cec9dee123423bd3d01e46d0844.tar.gz
gentoo-2-878e390465b17cec9dee123423bd3d01e46d0844.tar.bz2
gentoo-2-878e390465b17cec9dee123423bd3d01e46d0844.zip
Initial commit, ebuild by idella4
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/ChangeLog10
-rw-r--r--dev-python/pkginfo/Manifest3
-rw-r--r--dev-python/pkginfo/metadata.xml14
-rw-r--r--dev-python/pkginfo/pkginfo-0.8.ebuild61
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pkginfo/ChangeLog b/dev-python/pkginfo/ChangeLog
new file mode 100644
index 000000000000..427585fcee9d
--- /dev/null
+++ b/dev-python/pkginfo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pkginfo
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/ChangeLog,v 1.1 2012/04/27 12:49:29 tampakrap Exp $
+
+*pkginfo-0.8 (27 Apr 2012)
+
+ 27 Apr 2012; Theo Chatzimichos <tampakrap@gentoo.org> +metadata.xml,
+ +pkginfo-0.8.ebuild:
+ Initial commit, ebuild by idella4
+
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
new file mode 100644
index 000000000000..e2b3eddefd34
--- /dev/null
+++ b/dev-python/pkginfo/Manifest
@@ -0,0 +1,3 @@
+DIST pkginfo-0.8.tar.gz 22374 RMD160 ba986fa440be81477c446442d6c6b2ce480cfabe SHA1 05e7b8a266c26c2744695a33c6164243e2f7ec92 SHA256 5d37007c0ca72e41367bd2c1a9af6d5927996f516b6df7584110ef7cafd0efbb
+EBUILD pkginfo-0.8.ebuild 1296 RMD160 c6b7f3cd4553e2c55c367b96b180f09ca29a321d SHA1 ff2bddff96055d06e2b754d55a5ec2e7723b4060 SHA256 183016610adefe03a2c4f4533ef19456fc68daf3586c0a05d91ea0e1306816f1
+MISC metadata.xml 354 RMD160 091888911fc3977462b1015a07a860a68ab6ee9e SHA1 dfd9a92e0cdac92fbeccaae8038db941a4273b09 SHA256 286b386bcfeeacbeace854ed0f9904d845b8397b957963d95bae64534a6decb2
diff --git a/dev-python/pkginfo/metadata.xml b/dev-python/pkginfo/metadata.xml
new file mode 100644
index 000000000000..472ba4684030
--- /dev/null
+++ b/dev-python/pkginfo/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johneed@hotmail.com</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ <name>Theo Chatzimichos</name>
+ </maintainer>
+ <herd>python</herd>
+</pkgmetadata>
+
diff --git a/dev-python/pkginfo/pkginfo-0.8.ebuild b/dev-python/pkginfo/pkginfo-0.8.ebuild
new file mode 100644
index 000000000000..49278a55e028
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-0.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/pkginfo-0.8.ebuild,v 1.1 2012/04/27 12:49:29 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+inherit distutils eutils
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="http://pypi.python.org/pypi/pkginfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+LICENSE="MIT"
+SLOT="0"
+DEPEND="doc? ( dev-python/sphinx )
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's:SPHINXBUILD = sphinx-build:SPHINXBUILD = /usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+src_test() {
+ testing() {
+ pushd pkginfo/tests/ > /dev/null
+ for test in test_*.py; do
+ PYTHONPATH="../../build-${PYTHON_ABI}/lib/" \
+ "$(PYTHON)" "${test}" || die "${test} failed with Python ${PYTHON_ABI}"
+ if [[ $? ]]; then
+ einfo "Test "${test}" successful"
+ fi
+ done
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/.build/html/*
+ fi
+
+ if use examples; then
+ insinto usr/share/doc/${PF}/
+ doins -r docs/examples/
+ fi
+}