summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-03-24 02:17:55 +0000
committerMike Gilbert <floppym@gentoo.org>2013-03-24 02:17:55 +0000
commit33982ebd5ac15a67b863f7e2dc0be82db6a87846 (patch)
tree75b1492581bb4556a7a686ff1c72d4a3a241f020 /dev-python/psycopg
parentRemove dependency on unzip. (diff)
downloadgentoo-2-33982ebd5ac15a67b863f7e2dc0be82db6a87846.tar.gz
gentoo-2-33982ebd5ac15a67b863f7e2dc0be82db6a87846.tar.bz2
gentoo-2-33982ebd5ac15a67b863f7e2dc0be82db6a87846.zip
Add python3.3.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog7
-rw-r--r--dev-python/psycopg/psycopg-2.4.6-r2.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index 97ec08b262c3..3d2f28b07f05 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.158 2013/02/24 12:15:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.159 2013/03/24 02:17:55 floppym Exp $
+
+*psycopg-2.4.6-r2 (24 Mar 2013)
+
+ 24 Mar 2013; Mike Gilbert <floppym@gentoo.org> +psycopg-2.4.6-r2.ebuild:
+ Add python3.3.
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> psycopg-2.4.6-r1.ebuild:
Stable for x86, wrt bug #447470
diff --git a/dev-python/psycopg/psycopg-2.4.6-r2.ebuild b/dev-python/psycopg/psycopg-2.4.6-r2.ebuild
new file mode 100644
index 000000000000..9b3bb026eff4
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.4.6-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.6-r2.ebuild,v 1.1 2013/03/24 02:17:55 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples"
+
+RDEPEND=">=dev-db/postgresql-base-8.1"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile() {
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+
+ [[ ${EPYTHON} != python3* ]] && append-flags -fno-strict-aliasing
+
+ distutils-r1_python_compile
+}
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-2.4.2-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+ )
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+# if use mxdatetime; then
+# sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die
+# fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc -j1 html text
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc doc/{HACKING,SUCCESS}
+
+ if use doc; then
+ dodoc doc/psycopg2.txt
+ dohtml -r doc/html/.
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/.
+ fi
+}