summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-26 09:49:34 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-26 09:49:34 +0000
commit2e3061d38cb7c0eea688fb4a60fc5b22d1a91d18 (patch)
tree0ecac4b3a9c4fa12e368267a771778017cbfb2d2 /dev-python/pyatspi
parentRequire <app-cdr/brasero-3, bug #405077 by Andrew John Hughes. Drop old. (diff)
downloadgentoo-2-2e3061d38cb7c0eea688fb4a60fc5b22d1a91d18.tar.gz
gentoo-2-2e3061d38cb7c0eea688fb4a60fc5b22d1a91d18.tar.bz2
gentoo-2-2e3061d38cb7c0eea688fb4a60fc5b22d1a91d18.zip
Fix configure to disable tests properly, upstream bug #670823 by gokturk. Drop old.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/ChangeLog8
-rw-r--r--dev-python/pyatspi/files/pyatspi-2.2.1-configure-check.patch11
-rw-r--r--dev-python/pyatspi/pyatspi-2.0.2.ebuild76
-rw-r--r--dev-python/pyatspi/pyatspi-2.2.1.ebuild9
4 files changed, 23 insertions, 81 deletions
diff --git a/dev-python/pyatspi/ChangeLog b/dev-python/pyatspi/ChangeLog
index a108b6294a84..c60efe8a9988 100644
--- a/dev-python/pyatspi/ChangeLog
+++ b/dev-python/pyatspi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyatspi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.4 2012/02/10 03:40:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.5 2012/02/26 09:49:33 pacho Exp $
+
+ 26 Feb 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/pyatspi-2.2.1-configure-check.patch, -pyatspi-2.0.2.ebuild,
+ pyatspi-2.2.1.ebuild:
+ Fix configure to disable tests properly, upstream bug #670823 by gokturk. Drop
+ old.
10 Feb 2012; Patrick Lauer <patrick@gentoo.org> pyatspi-2.0.2.ebuild,
pyatspi-2.2.1.ebuild:
diff --git a/dev-python/pyatspi/files/pyatspi-2.2.1-configure-check.patch b/dev-python/pyatspi/files/pyatspi-2.2.1-configure-check.patch
new file mode 100644
index 000000000000..14279f6aa3cd
--- /dev/null
+++ b/dev-python/pyatspi/files/pyatspi-2.2.1-configure-check.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2012-02-11 21:00:51.650000004 -0500
++++ configure.ac 2012-02-11 21:01:02.680000006 -0500
+@@ -25,7 +25,7 @@
+ AC_MSG_CHECKING([whether tests are enabled])
+ AC_ARG_ENABLE(tests,
+ [AS_HELP_STRING([--enable-tests], [Build with testing enabled])],
+- enable_tests=yes,
++ enable_tests=$enableval,
+ enable_tests=no)
+ AC_MSG_RESULT($enable_tests)
+ AM_CONDITIONAL(ENABLE_TESTING, test x$enable_tests == xyes)
diff --git a/dev-python/pyatspi/pyatspi-2.0.2.ebuild b/dev-python/pyatspi/pyatspi-2.0.2.ebuild
deleted file mode 100644
index 6c4ead3c7773..000000000000
--- a/dev-python/pyatspi/pyatspi-2.0.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.0.2.ebuild,v 1.3 2012/02/10 03:40:59 patrick Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit gnome2 python
-
-DESCRIPTION="Python binding to at-spi library"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-COMMON_DEPEND="dev-python/dbus-python
- >=dev-python/pygobject-2.26:2
-"
-RDEPEND="${COMMON_DEPEND}
- >=sys-apps/dbus-1
- !<gnome-extra/at-spi-1.32.0-r1
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/pkgconfig
- test? (
- >=dev-libs/atk-1.17
- >=dev-libs/dbus-glib-0.7
- dev-libs/glib:2
- dev-libs/libxml2:2
- >=x11-libs/gtk+-2.10:2 )"
-
-pkg_setup() {
- G2CONF="${G2CONF} $(use_enable test tests)"
- python_pkg_setup
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # disable pyc compiling
- echo '#!/bin/sh' > config/py-compile
-
- python_copy_sources
-}
-
-src_configure() {
- python_execute_function -s gnome2_src_configure
-}
-
-src_compile() {
- python_execute_function -s gnome2_src_compile
-}
-
-src_test() {
- python_execute_function -s -d
-}
-
-src_install() {
- python_execute_function -s gnome2_src_install
- python_clean_installation_image
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- python_mod_optimize pyatspi
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup pyatspi
-}
diff --git a/dev-python/pyatspi/pyatspi-2.2.1.ebuild b/dev-python/pyatspi/pyatspi-2.2.1.ebuild
index c75d845462de..b807cb5677f4 100644
--- a/dev-python/pyatspi/pyatspi-2.2.1.ebuild
+++ b/dev-python/pyatspi/pyatspi-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.2.1.ebuild,v 1.3 2012/02/10 03:40:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.2.1.ebuild,v 1.4 2012/02/26 09:49:33 pacho Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -42,6 +42,9 @@ pkg_setup() {
}
src_prepare() {
+ # Fix configure to disable tests properly, upstream bug #670823
+ epatch "${FILESDIR}/${PN}-2.2.1-configure-check.patch"
+
# remove pygtk cruft; https://bugzilla.gnome.org/show_bug.cgi?id=660826
# requires eautoreconf
epatch "${FILESDIR}/${PN}-2.2.0-AM_CHECK_PYMOD-pygtk.patch"
@@ -49,9 +52,7 @@ src_prepare() {
gnome2_src_prepare
- # disable pyc compiling
- echo '#!/bin/sh' > config/py-compile
-
+ python_clean_py-compile_files
python_copy_sources
}