summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-15 15:25:13 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-15 15:25:13 +0000
commit0904d62993ceff5f30f3cbbdc05cdf86a9b172fd (patch)
treeb2e2a4ff1440d980fce1d32a953cd6a1df84bfb0 /dev-python/pycuda
parentFix docompress call in src_install (diff)
downloadgentoo-2-0904d62993ceff5f30f3cbbdc05cdf86a9b172fd.tar.gz
gentoo-2-0904d62993ceff5f30f3cbbdc05cdf86a9b172fd.tar.bz2
gentoo-2-0904d62993ceff5f30f3cbbdc05cdf86a9b172fd.zip
dev-python/pycuda: Version Bump; bump to EAPI=5 and distutils-r1.eclass; depend on libcuda.so, #403729
(Portage version: 2.2.0_alpha152/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/ChangeLog11
-rw-r--r--dev-python/pycuda/metadata.xml12
-rw-r--r--dev-python/pycuda/pycuda-2012.1.ebuild88
3 files changed, 103 insertions, 8 deletions
diff --git a/dev-python/pycuda/ChangeLog b/dev-python/pycuda/ChangeLog
index 91c45ac4acb9..359906a5d174 100644
--- a/dev-python/pycuda/ChangeLog
+++ b/dev-python/pycuda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pycuda
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.17 2012/11/08 06:32:59 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/ChangeLog,v 1.18 2013/01/15 15:25:13 jlec Exp $
+
+*pycuda-2012.1 (15 Jan 2013)
+
+ 15 Jan 2013; Justin Lecher <jlec@gentoo.org> +pycuda-2012.1.ebuild,
+ metadata.xml:
+ Version Bump; bump to EAPI=5 and distutils-r1.eclass; depend on libcuda.so,
+ #403729
08 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> -pycuda-2011.2.2.ebuild:
Remove old version depending on older boost.
diff --git a/dev-python/pycuda/metadata.xml b/dev-python/pycuda/metadata.xml
index e4705c8632e0..5d6640e9c329 100644
--- a/dev-python/pycuda/metadata.xml
+++ b/dev-python/pycuda/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>spock@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pycuda</remote-id>
- </upstream>
+ <maintainer>
+ <email>spock@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pycuda</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pycuda/pycuda-2012.1.ebuild b/dev-python/pycuda/pycuda-2012.1.ebuild
new file mode 100644
index 000000000000..4c1feda1eb4c
--- /dev/null
+++ b/dev-python/pycuda/pycuda-2012.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-2012.1.ebuild,v 1.1 2013/01/15 15:25:13 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit cuda distutils-r1 multilib
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="http://mathema.tician.de/software/pycuda/ http://pypi.python.org/pypi/pycuda"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl test"
+
+RDEPEND="
+ dev-libs/boost[python]
+ dev-python/decorator
+ dev-python/mako
+ dev-python/numpy
+ >=dev-python/pytools-2011.2
+ dev-util/nvidia-cuda-toolkit
+ x11-drivers/nvidia-drivers
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mako
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
+# user is (usually) not in the video group
+RESTRICT="userpriv"
+
+src_prepare() {
+ cuda_sanitize
+ sed \
+ -e "s:'--preprocess':\'--preprocess\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
+ -e "s:\"--cubin\":\'--cubin\', \'--compiler-bindir=$(cuda_gccdir)\':g" \
+ -e "s:/usr/include/pycuda:${S}/src/cuda:g" \
+ -i pycuda/compiler.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ local myopts=()
+ use opengl && myopts+=( --cuda-enable-gl )
+
+ compilation() {
+ [[ -e ./siteconf.py ]] && rm -f ./siteconf.py
+ "${EPYTHON}" configure.py \
+ --boost-inc-dir="${EPREFIX}/usr/include" \
+ --boost-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --boost-python-libname=boost_python-$(echo ${EPYTHON} | sed 's/python//')-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --cuda-root="${EPREFIX}/opt/cuda" \
+ --cudadrv-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --cudart-lib-dir="${EPREFIX}/opt/cuda/$(get_libdir)" \
+ --cuda-inc-dir="${EPREFIX}/opt/cuda/include" \
+ --no-use-shipped-boost \
+ "${myopts[@]}"
+ distutils-r1_python_compile
+ }
+ python_foreach_impl compilation
+}
+
+src_test() {
+ # we need write access to this to run the tests
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ python_test() {
+ py.test --debug -v -v -v || die "Tests fail with ${EPYTHON}"
+ }
+ distutils-r1_src_test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}