summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:23:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-17 06:23:19 +0000
commit0ae558ac60f6d724e05dc78f39734dcbdfcb9f83 (patch)
treed2832bdde4ce0b9c4ffbd2cb092d74f78154b3cd /dev-python/pyface
parentVersion bump (diff)
downloadgentoo-2-0ae558ac60f6d724e05dc78f39734dcbdfcb9f83.tar.gz
gentoo-2-0ae558ac60f6d724e05dc78f39734dcbdfcb9f83.tar.bz2
gentoo-2-0ae558ac60f6d724e05dc78f39734dcbdfcb9f83.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyface')
-rw-r--r--dev-python/pyface/ChangeLog9
-rw-r--r--dev-python/pyface/pyface-4.1.0.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-python/pyface/ChangeLog b/dev-python/pyface/ChangeLog
index 06d7595419b9..3eb0c93a4029 100644
--- a/dev-python/pyface/ChangeLog
+++ b/dev-python/pyface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyface
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.1 2011/08/03 23:48:32 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/ChangeLog,v 1.2 2012/01/17 06:23:19 bicatali Exp $
+
+*pyface-4.1.0 (17 Jan 2012)
+
+ 17 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +pyface-4.1.0.ebuild:
+ Version bump
*pyface-4.0.0 (03 Aug 2011)
diff --git a/dev-python/pyface/pyface-4.1.0.ebuild b/dev-python/pyface/pyface-4.1.0.ebuild
new file mode 100644
index 000000000000..4e74ea78d9d9
--- /dev/null
+++ b/dev-python/pyface/pyface-4.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyface/pyface-4.1.0.ebuild,v 1.1 2012/01/17 06:23:19 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface http://pypi.python.org/pypi/pyface"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/traits-4.1
+ || ( dev-python/wxpython dev-python/PyQt4 dev-python/pyside )"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS="docs/*.txt"
+
+src_compile() {
+ distutils_src_compile
+ use doc && emake -C docs html
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}