summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:08:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:08:30 +0000
commitccdacfc2f4bdc6163bc066d0e98d8207aff6904b (patch)
treef3607ca10282572e72e1e794efc49f294e60d31c /dev-python/pyfltk
parentUse $(PYTHON -f) instead of ${python}. (diff)
downloadgentoo-2-ccdacfc2f4bdc6163bc066d0e98d8207aff6904b.tar.gz
gentoo-2-ccdacfc2f4bdc6163bc066d0e98d8207aff6904b.tar.bz2
gentoo-2-ccdacfc2f4bdc6163bc066d0e98d8207aff6904b.zip
Use $(PYTHON -f) instead of ${python}.
(Portage version: 15324-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyfltk')
-rw-r--r--dev-python/pyfltk/pyfltk-1.1.4.ebuild19
-rw-r--r--dev-python/pyfltk/pyfltk-1.1.5.ebuild17
2 files changed, 19 insertions, 17 deletions
diff --git a/dev-python/pyfltk/pyfltk-1.1.4.ebuild b/dev-python/pyfltk/pyfltk-1.1.4.ebuild
index 8fc87f2755e3..0261279704fa 100644
--- a/dev-python/pyfltk/pyfltk-1.1.4.ebuild
+++ b/dev-python/pyfltk/pyfltk-1.1.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.4.ebuild,v 1.6 2009/11/24 00:03:53 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.4.ebuild,v 1.7 2010/02/06 15:08:30 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit eutils distutils
@@ -22,15 +23,14 @@ IUSE="doc"
RDEPEND=">=x11-libs/fltk-1.1.9:1.1[opengl]"
DEPEND="${RDEPEND}
dev-lang/swig"
-
-RESTRICT_PYTHON_ABIS="3*"
-
-PYTHON_MODNAME="fltk"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
DOCS="CHANGES"
+PYTHON_MODNAME="fltk"
+
src_prepare() {
rm -f python/fltk*
# move docs because the swig stuff will remove them
@@ -38,9 +38,10 @@ src_prepare() {
}
src_compile() {
- cd "${S}"/python
- ${python} MakeSwig.py || die "swigging wrappers failed"
- cd "${S}"
+ pushd python > /dev/null
+ "$(PYTHON -f)" MakeSwig.py || die "swigging wrappers failed"
+ popd > /dev/null
+
distutils_src_compile
}
diff --git a/dev-python/pyfltk/pyfltk-1.1.5.ebuild b/dev-python/pyfltk/pyfltk-1.1.5.ebuild
index 1a21fb25bd99..665f1eda5aa3 100644
--- a/dev-python/pyfltk/pyfltk-1.1.5.ebuild
+++ b/dev-python/pyfltk/pyfltk-1.1.5.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.5.ebuild,v 1.1 2010/01/21 01:33:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfltk/pyfltk-1.1.5.ebuild,v 1.2 2010/02/06 15:08:30 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit eutils distutils
@@ -22,15 +23,14 @@ IUSE="doc"
RDEPEND=">=x11-libs/fltk-1.1.9:1.1[opengl]"
DEPEND="${RDEPEND}
dev-lang/swig"
-
-RESTRICT_PYTHON_ABIS="3*"
-
-PYTHON_MODNAME="fltk"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
DOCS="CHANGES"
+PYTHON_MODNAME="fltk"
+
src_prepare() {
rm -f python/fltk*
# move docs because the swig stuff will remove them
@@ -38,9 +38,10 @@ src_prepare() {
}
src_compile() {
- cd "${S}"/python
- ${python} MakeSwig.py || die "swigging wrappers failed"
- cd "${S}"
+ pushd python > /dev/null
+ "$(PYTHON -f)" MakeSwig.py || die "swigging wrappers failed"
+ popd > /dev/null
+
distutils_src_compile
}