summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-24 14:41:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-24 14:41:47 +0000
commite69f5fd6008a6180828f526af863d152a64dc929 (patch)
tree8cbb5bf86c668091c3db29c7d52fb7a4d1c9f36f /dev-python/pygobject
parentFix build error when bashdb is installed, bug #276794 (diff)
downloadgentoo-2-e69f5fd6008a6180828f526af863d152a64dc929.tar.gz
gentoo-2-e69f5fd6008a6180828f526af863d152a64dc929.tar.bz2
gentoo-2-e69f5fd6008a6180828f526af863d152a64dc929.zip
Compile tests/ only if "make check" is requested wrt #226345. Run eautoreconf after touching py-compile or timestamp is changed and maintainer-mode will run wrt #259832.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog8
-rw-r--r--dev-python/pygobject/files/pygobject-2.18.0-make_check.patch12
-rw-r--r--dev-python/pygobject/pygobject-2.18.0.ebuild8
3 files changed, 24 insertions, 4 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 9780cfaf312c..c33263220ca5 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.67 2009/07/24 09:08:44 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.68 2009/07/24 14:41:47 ssuominen Exp $
+
+ 24 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ pygobject-2.18.0.ebuild, +files/pygobject-2.18.0-make_check.patch:
+ Compile tests/ only if "make check" is requested wrt #226345. Run
+ eautoreconf after touching py-compile or timestamp is changed and
+ maintainer-mode will run wrt #259832.
24 Jul 2009; Mart Raudsepp <leio@gentoo.org> pygobject-2.18.0.ebuild:
Various QA fixes before stabilization
diff --git a/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch b/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch
new file mode 100644
index 000000000000..f0f987e03638
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch
@@ -0,0 +1,12 @@
+diff -ur pygobject-2.18.0.orig/tests/Makefile.am pygobject-2.18.0/tests/Makefile.am
+--- pygobject-2.18.0.orig/tests/Makefile.am 2009-05-14 00:56:45.000000000 +0300
++++ pygobject-2.18.0/tests/Makefile.am 2009-07-24 17:26:27.000000000 +0300
+@@ -11,7 +11,7 @@
+ test-thread.h \
+ test-unknown.h
+
+-noinst_LTLIBRARIES = testhelper.la
++check_LTLIBRARIES = testhelper.la
+ linked_LIBS = testhelper.la
+
+ testhelper_la_LDFLAGS = -module -avoid-version
diff --git a/dev-python/pygobject/pygobject-2.18.0.ebuild b/dev-python/pygobject/pygobject-2.18.0.ebuild
index a09b25fc6a3e..9609946604eb 100644
--- a/dev-python/pygobject/pygobject-2.18.0.ebuild
+++ b/dev-python/pygobject/pygobject-2.18.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.18.0.ebuild,v 1.3 2009/07/24 09:08:44 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.18.0.ebuild,v 1.4 2009/07/24 14:41:47 ssuominen Exp $
inherit autotools gnome2 python virtualx
@@ -35,14 +35,16 @@ src_unpack() {
# Fix FHS compliance, see upstream bug #535524
epatch "${FILESDIR}/${PN}-2.15.4-fix-codegen-location.patch"
+ epatch "${FILESDIR}"/${P}-make_check.patch
+
# needed to build on a libtool-1 system, bug #255542
rm m4/lt* m4/libtool.m4 ltmain.sh
- eautoreconf
-
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile
+
+ eautoreconf
}
src_test() {