summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2009-09-09 18:31:08 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2009-09-09 18:31:08 +0000
commit28caf696a269ca28dfd9ea2b8455381060971d86 (patch)
treea01004cb8eeab488564563f92e83ab4aa6ed358e /dev-python/pygtk
parentBump. Modified ebuild thanks to Henrik Grubbstroem. Fixes #275644 #277936 (diff)
downloadgentoo-2-28caf696a269ca28dfd9ea2b8455381060971d86.tar.gz
gentoo-2-28caf696a269ca28dfd9ea2b8455381060971d86.tar.bz2
gentoo-2-28caf696a269ca28dfd9ea2b8455381060971d86.zip
Fix crash in gdk.color_from_hsv. (Bug #283093)
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog8
-rw-r--r--dev-python/pygtk/files/pygtk-2.16.0-gdkcolor-fix.patch12
-rw-r--r--dev-python/pygtk/pygtk-2.16.0-r1.ebuild109
3 files changed, 128 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 079a1215ec8c..0abe0ab1d648 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.222 2009/09/06 20:57:05 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.223 2009/09/09 18:31:08 ford_prefect Exp $
+
+*pygtk-2.16.0-r1 (09 Sep 2009)
+
+ 09 Sep 2009; Arun Raghavan <ford_prefect@gentoo.org>
+ +pygtk-2.16.0-r1.ebuild, +files/pygtk-2.16.0-gdkcolor-fix.patch:
+ Fix crash in gdk.color_from_hsv. (Bug #283093)
06 Sep 2009; Brent Baude <ranger@gentoo.org> pygtk-2.14.1-r1.ebuild:
Marking pygtk-2.14.1-r1 ppc64 for bug 279391
diff --git a/dev-python/pygtk/files/pygtk-2.16.0-gdkcolor-fix.patch b/dev-python/pygtk/files/pygtk-2.16.0-gdkcolor-fix.patch
new file mode 100644
index 000000000000..76646bf82a2f
--- /dev/null
+++ b/dev-python/pygtk/files/pygtk-2.16.0-gdkcolor-fix.patch
@@ -0,0 +1,12 @@
+diff -urNp pygtk-2.16.0-orig/gtk/gdkcolor.override pygtk-2.16.0/gtk/gdkcolor.override
+--- pygtk-2.16.0-orig/gtk/gdkcolor.override 2009-09-07 11:24:02.000000000 +0530
++++ pygtk-2.16.0/gtk/gdkcolor.override 2009-09-07 11:24:11.000000000 +0530
+@@ -139,7 +139,7 @@ _wrap_gdk_color_new(PyGBoxed *self,
+ }
+
+ %%
+-define color_from_hsv
++define color_from_hsv kwargs
+ static PyObject *
+ _wrap_color_from_hsv (PyObject *ignored, PyObject *args, PyObject*kwargs)
+ {
diff --git a/dev-python/pygtk/pygtk-2.16.0-r1.ebuild b/dev-python/pygtk/pygtk-2.16.0-r1.ebuild
new file mode 100644
index 000000000000..4608ebe35c1b
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.16.0-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.16.0-r1.ebuild,v 1.1 2009/09/09 18:31:08 ford_prefect Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/pango-1.16.0
+ >=dev-libs/atk-1.12.0
+ >=x11-libs/gtk+-2.13.6
+ >=gnome-base/libglade-2.5.0
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pycairo-1.0.2
+ >=dev-python/pygobject-2.15.3
+ dev-python/numpy"
+
+DEPEND="${RDEPEND}
+ doc? (
+ dev-libs/libxslt
+ >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.9"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_prepare() {
+ # Fix declaration of codegen in .pc
+ epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
+
+ # Fix a crash in gdk.color_from_hsv
+ epatch "${FILESDIR}/${P}-gdkcolor-fix.patch"
+
+ # Disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ AT_M4DIR="m4" eautoreconf
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ use hppa && append-flags -ffunction-sections
+ econf $(use_enable doc docs) --enable-thread
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ python_execute_function -d -s
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ testing() {
+ if has ${PYTHON_ABI} 2.4 2.5; then
+ einfo "Skipping tests with Python ${PYTHON_ABI}. dev-python/pycairo supports only Python >=2.6."
+ return 0
+ fi
+
+ cd tests
+ Xemake check-local
+ }
+ python_execute_function -s testing
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize gtk-2.0
+
+ create_symlinks() {
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
+ }
+ python_execute_function create_symlinks
+}
+
+pkg_postrm() {
+ python_mod_cleanup gtk-2.0
+
+ create_symlinks() {
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
+ }
+ python_execute_function create_symlinks
+}