summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-29 17:18:38 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-29 17:18:38 +0000
commit0ecdf22eba8b361037e76e1f9c3ac95e29b004c6 (patch)
tree5eb3e1fda8ecece40db588fcd3f64fa5383b213a /dev-python/pyinotify
parentrevbump, migrate -> distutils-r1 (diff)
downloadgentoo-2-0ecdf22eba8b361037e76e1f9c3ac95e29b004c6.tar.gz
gentoo-2-0ecdf22eba8b361037e76e1f9c3ac95e29b004c6.tar.bz2
gentoo-2-0ecdf22eba8b361037e76e1f9c3ac95e29b004c6.zip
drop pypy1.8 support, add pypy2_0
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyinotify')
-rw-r--r--dev-python/pyinotify/ChangeLog5
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild10
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/pyinotify/ChangeLog b/dev-python/pyinotify/ChangeLog
index e3588743272d..f853a01f0866 100644
--- a/dev-python/pyinotify/ChangeLog
+++ b/dev-python/pyinotify/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyinotify
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.56 2013/05/16 13:19:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/ChangeLog,v 1.57 2013/05/29 17:18:38 idella4 Exp $
+
+ 29 May 2013; Ian Delaney <idella4@gentoo.org> pyinotify-0.9.4-r1.ebuild:
+ drop pypy1.8 support, add pypy2_0
16 May 2013; Agostino Sarubbo <ago@gentoo.org> pyinotify-0.9.4-r1.ebuild:
Stable for ppc, wrt bug #467130
diff --git a/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
index 4dab3d0165d0..59eb6246f0c4 100644
--- a/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
+++ b/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild,v 1.7 2013/05/16 13:19:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinotify/pyinotify-0.9.4-r1.ebuild,v 1.8 2013/05/29 17:18:38 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
inherit distutils-r1
@@ -20,8 +20,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
python_install_all() {
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins python2/examples/* || die "Installation of examples failed"
- fi
+ use examples && local EXAMPLES=( python2/examples/. )
+ distutils-r1_python_install_all
}