summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-17 12:25:34 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-17 12:25:34 +0000
commit4e1a64cc217cb2a0a7041d31a948efda308fd081 (patch)
tree40d8b81c9a8a0954cfb2c4fd2fafbd9e805efb5b /dev-python/pykde
parentRemoved some hunks which reintroduced some bugs (diff)
downloadgentoo-2-4e1a64cc217cb2a0a7041d31a948efda308fd081.tar.gz
gentoo-2-4e1a64cc217cb2a0a7041d31a948efda308fd081.tar.bz2
gentoo-2-4e1a64cc217cb2a0a7041d31a948efda308fd081.zip
moving from PyKDE to pykde
Diffstat (limited to 'dev-python/pykde')
-rw-r--r--dev-python/pykde/ChangeLog9
-rw-r--r--dev-python/pykde/Manifest4
-rw-r--r--dev-python/pykde/files/digest-pykde-3.5.21
-rw-r--r--dev-python/pykde/files/pykde-3.5.2-sandbox-patch.diff20
-rw-r--r--dev-python/pykde/pykde-3.5.2.ebuild51
5 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/pykde/ChangeLog b/dev-python/pykde/ChangeLog
new file mode 100644
index 000000000000..9edb0b54f708
--- /dev/null
+++ b/dev-python/pykde/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pykde
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pykde/ChangeLog,v 1.1 2003/04/17 12:25:27 liquidx Exp $
+
+*pykde-3.5.2 (14 Apr 2003)
+
+ 14 Apr 2003; Michele Balistreri <brain@gentoo.org> PyKDE-3.5.2.ebuild:
+ Initial import. Ebuild submitted by Paul Pacheco <paul.pacheco@wavecode.com>
+
diff --git a/dev-python/pykde/Manifest b/dev-python/pykde/Manifest
new file mode 100644
index 000000000000..e04d426e8701
--- /dev/null
+++ b/dev-python/pykde/Manifest
@@ -0,0 +1,4 @@
+MD5 8ab00eaeb5d7b73c6c02b7c3d133396b pykde-3.5.2.ebuild 1262
+MD5 0a9ffdba20886e43d0ffcf889fc5dfdb ChangeLog 396
+MD5 87cf4dfaa7eb6c2dc39268151690e347 files/pykde-3.5.2-sandbox-patch.diff 763
+MD5 0724bcacc7dc67d7071ec4a38828db1a files/digest-pykde-3.5.2 63
diff --git a/dev-python/pykde/files/digest-pykde-3.5.2 b/dev-python/pykde/files/digest-pykde-3.5.2
new file mode 100644
index 000000000000..98b4f703b632
--- /dev/null
+++ b/dev-python/pykde/files/digest-pykde-3.5.2
@@ -0,0 +1 @@
+MD5 b80d43ab8c6762f985fef274791d174d PyKDE-3.5-2.tar.gz 742367
diff --git a/dev-python/pykde/files/pykde-3.5.2-sandbox-patch.diff b/dev-python/pykde/files/pykde-3.5.2-sandbox-patch.diff
new file mode 100644
index 000000000000..0b26888c96a0
--- /dev/null
+++ b/dev-python/pykde/files/pykde-3.5.2-sandbox-patch.diff
@@ -0,0 +1,20 @@
+--- build.py.orig 2003-04-09 07:17:13.000000000 +0200
++++ build.py 2003-04-13 19:52:32.000000000 +0200
+@@ -651,7 +651,7 @@
+
+
+ def checkThreading ():
+- qtmodlib = modDir + '/libqtcmodule.so'
++ qtmodlib = sipModuleDir + '/libqtcmodule.so'
+ os.system ('ldd ' + qtmodlib + ' > lddtmp')
+ f = open ('lddtmp', 'r')
+ buff = f.read ()
+@@ -843,7 +843,7 @@
+ if sipModuleDir is None:
+ error("The SIP module/library could not be found. Use the -s argument to set the correct directory")
+
+- proPatches["LIBS"] = [re.compile("@BL_SIPMODDIR@",re.M), sipModuleDir]
++ proPatches["LIBS"] = [re.compile("@BL_SIPMODDIR@",re.M), (sipModuleDir + " -L" + modDir)]
+
+ inform("%s contains the SIP module." % (sipModuleDir))
+
diff --git a/dev-python/pykde/pykde-3.5.2.ebuild b/dev-python/pykde/pykde-3.5.2.ebuild
new file mode 100644
index 000000000000..e5344c66080f
--- /dev/null
+++ b/dev-python/pykde/pykde-3.5.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pykde/pykde-3.5.2.ebuild,v 1.1 2003/04/17 12:25:27 liquidx Exp $
+
+inherit eutils
+
+MAJ_PV=${PV%.[0-9]*}
+MIN_PV=${PV##*[0-9].}
+MY_PN="PyKDE"
+MY_P=${MY_PN}-${MAJ_PV}-${MIN_PV}
+
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="PyKDE is a set of Python bindings for the KDE libs"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyKDE2/${MY_P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pykde/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=dev-lang/python-2.2.1
+ >=dev-python/sip-3.5
+ >=dev-python/PyQt-3.5-r1
+ kde-base/kdelibs"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${MY_P}-sandbox-patch.diff
+}
+
+src_compile() {
+ dodir /usr/lib/python2.2/site-packages
+ dodir /usr/include/python2.2
+ python build.py \
+ -d ${D}/usr/lib/python2.2/site-packages \
+ -s /usr/lib/python2.2/site-packages \
+ -u ${KDEDIR}/lib \
+ -c -l qt-mt -v /usr/share/sip/qt || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog AUTHORS THANKS README
+ dodir /usr/share/doc/${P}/
+ mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
+}
+
+