summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-10 17:22:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-10 17:22:33 +0000
commitc3ad9bc03894455f7c06925812e198f3f73f7edd (patch)
tree42d523cd428cd27b7e8706be445b86dac5e0e64f /dev-python/pylibacl
parentwhitespace (diff)
downloadgentoo-2-c3ad9bc03894455f7c06925812e198f3f73f7edd.tar.gz
gentoo-2-c3ad9bc03894455f7c06925812e198f3f73f7edd.tar.bz2
gentoo-2-c3ad9bc03894455f7c06925812e198f3f73f7edd.zip
Version bump.
(Portage version: 15816-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/ChangeLog10
-rw-r--r--dev-python/pylibacl/pylibacl-0.5.0.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/pylibacl/ChangeLog b/dev-python/pylibacl/ChangeLog
index e259d55a69f6..3908906758db 100644
--- a/dev-python/pylibacl/ChangeLog
+++ b/dev-python/pylibacl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylibacl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.26 2009/11/14 15:46:01 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.27 2010/03/10 17:22:33 arfrever Exp $
+
+*pylibacl-0.5.0 (10 Mar 2010)
+
+ 10 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pylibacl-0.5.0.ebuild:
+ Version bump.
14 Nov 2009; Raúl Porcel <armin76@gentoo.org> pylibacl-0.4.0-r1.ebuild:
ia64/sh/sparc stable wrt #287581
diff --git a/dev-python/pylibacl/pylibacl-0.5.0.ebuild b/dev-python/pylibacl/pylibacl-0.5.0.ebuild
new file mode 100644
index 000000000000..e97e9189ec4f
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/pylibacl-0.5.0.ebuild,v 1.1 2010/03/10 17:22:33 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="http://sourceforge.net/projects/pylibacl/ http://pypi.python.org/pypi/pylibacl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/acl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+# Tests are missing in the tarball.
+RESTRICT="test"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" test/test_acls.py || \
+ {
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ return 1
+ }
+ }
+ python_execute_function testing
+}