summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-09 02:51:16 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-09 02:51:16 +0000
commit28ac9aa98ab7981e05263099377ca36445edd58e (patch)
treeb3211ba92316f9dc6de92bd4a1f49070f1eb3c17 /dev-python/pylint
parent0.11.1 version bump (diff)
downloadgentoo-2-28ac9aa98ab7981e05263099377ca36445edd58e.tar.gz
gentoo-2-28ac9aa98ab7981e05263099377ca36445edd58e.tar.bz2
gentoo-2-28ac9aa98ab7981e05263099377ca36445edd58e.zip
bump; drop py2.6 py3.2 pypy2_0 add py3.4 support, update test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-1.2.1.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 60f684dae259..34c730bb5a48 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.106 2014/02/16 10:34:43 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.107 2014/05/09 02:51:16 idella4 Exp $
+
+*pylint-1.2.1 (09 May 2014)
+
+ 09 May 2014; Ian Delaney <idella4@gentoo.org> +pylint-1.2.1.ebuild,
+ pylint-1.1.0.ebuild:
+ bump; drop py2.6 py3.2 pypy2_0 add py3.4 support, update test phase
*pylint-1.1.0 (16 Feb 2014)
diff --git a/dev-python/pylint/pylint-1.2.1.ebuild b/dev-python/pylint/pylint-1.2.1.ebuild
new file mode 100644
index 000000000000..8ac58cb8e6b3
--- /dev/null
+++ b/dev-python/pylint/pylint-1.2.1.ebuild
@@ -0,0 +1,67 @@
+
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.2.1.ebuild,v 1.1 2014/05/09 02:51:16 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+# Versions specified in __pkginfo__.py; 'logilab-common >= 0.53.0,' 'astroid >= 0.24.3'
+# New addition of atroid to portage is 1.0.1, >=dev-python/astroid-0.24.3 making limited sense
+RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
+ >=dev-python/astroid-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( "${RDEPEND}" )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )
+
+# Usual. Requ'd for impl specific failures in test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all () {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && emake -C doc singlehtml
+ distutils-r1_python_prepare_all
+}
+
+
+python_test() {
+ # Test suite appears not to work under Python 3.
+ # https://bitbucket.org/logilab/pylint/issue/240/
+ local msg="Test suite broken with ${EPYTHON}"
+ if [[ "${EPYTHON}" == python3* ]]; then
+ einfo "${msg}"
+ return 0
+ elif [[ "${EPYTHON}" == "pypy" ]]; then
+ sed -e 's:test_functionality:_&:g' -i build/lib/pylint/testutils.py || die
+ sed -e 's:test_exhaustivity:_&:' -i test/test_func.py || die
+ fi
+
+ sed -e 's:test_analyze_explicit_script:_&:' -i test/unittest_lint.py || die
+ pytest || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ use examples && local EXAMPLES=( examples/. )
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}