summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-24 12:41:51 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-24 12:41:51 +0000
commit4ede966c715476fb3ce8f0121616095477c716d3 (patch)
tree3fce4068616e71b824ebbc597f51be08606e1e4b /dev-python/pylint
parentBump PATCH_VER. (diff)
downloadgentoo-2-4ede966c715476fb3ce8f0121616095477c716d3.tar.gz
gentoo-2-4ede966c715476fb3ce8f0121616095477c716d3.tar.bz2
gentoo-2-4ede966c715476fb3ce8f0121616095477c716d3.zip
dev-python/pylint: Add missing call of distutils-r1_python_install_all()
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog6
-rw-r--r--dev-python/pylint/metadata.xml10
-rw-r--r--dev-python/pylint/pylint-0.28.0.ebuild8
3 files changed, 15 insertions, 9 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index a391dd2b3c24..265d40ddc293 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.103 2013/08/21 10:45:07 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.104 2013/09/24 12:41:51 jlec Exp $
+
+ 24 Sep 2013; Justin Lecher <jlec@gentoo.org> pylint-0.28.0.ebuild,
+ metadata.xml:
+ Add missing call of distutils-r1_python_install_all()
21 Aug 2013; Dirkjan Ochtman <djc@gentoo.org> -pylint-0.25.0.ebuild,
-pylint-0.25.1.ebuild, -pylint-0.25.2.ebuild, -pylint-0.26.0.ebuild,
diff --git a/dev-python/pylint/metadata.xml b/dev-python/pylint/metadata.xml
index f9fbc27b10c3..a108538b650b 100644
--- a/dev-python/pylint/metadata.xml
+++ b/dev-python/pylint/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <longdescription lang="en">Pylint is a Python source code analyzer which looks for programming
+ <herd>python</herd>
+ <longdescription lang="en">Pylint is a Python source code analyzer which looks for programming
errors, helps enforcing a coding standard and sniffs for some code
smells (as defined in Martin Fowler's Refactoring book).
Pylint can be seen as another PyChecker since nearly all tests you can
@@ -11,7 +11,7 @@
variable names are well-formed according to your coding standard, or
checking if declared interfaces are truly implemented, and much more.
Additionally, it is possible to write plugins to add your own checks.</longdescription>
- <upstream>
- <remote-id type="pypi">pylint</remote-id>
- </upstream>
+ <upstream>
+ <remote-id type="pypi">pylint</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/pylint/pylint-0.28.0.ebuild b/dev-python/pylint/pylint-0.28.0.ebuild
index d0dced3da169..798242126577 100644
--- a/dev-python/pylint/pylint-0.28.0.ebuild
+++ b/dev-python/pylint/pylint-0.28.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.3 2013/06/26 01:38:28 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.28.0.ebuild,v 1.4 2013/09/24 12:41:51 jlec Exp $
EAPI=5
+
PYTHON_COMPAT=( python{2_6,2_7,3_2} )
inherit distutils-r1
@@ -40,11 +41,12 @@ python_test() {
}
python_install_all() {
- doman man/{pylint,pyreverse}.1 || die "doman failed"
+ distutils-r1_python_install_all
+ doman man/{pylint,pyreverse}.1
if use examples; then
docinto examples
- dodoc examples/* || die "dodoc failed"
+ dodoc examples/*
fi
}