summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-11 06:14:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-11 06:14:51 +0000
commitf5a0a518aed35227a0de68922a4e11bc9078f8f9 (patch)
treebf19a4a173b828068d2169fe7a329945ffe34ee7 /dev-python/pylint
parentBump (diff)
downloadgentoo-2-f5a0a518aed35227a0de68922a4e11bc9078f8f9.tar.gz
gentoo-2-f5a0a518aed35227a0de68922a4e11bc9078f8f9.tar.bz2
gentoo-2-f5a0a518aed35227a0de68922a4e11bc9078f8f9.zip
Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog7
-rw-r--r--dev-python/pylint/pylint-0.27.0.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index fbd3452cd100..cf7747c3ffc7 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.93 2013/02/02 22:29:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.94 2013/03/11 06:14:51 patrick Exp $
+
+*pylint-0.27.0 (11 Mar 2013)
+
+ 11 Mar 2013; Patrick Lauer <patrick@gentoo.org> +pylint-0.27.0.ebuild:
+ Bump
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> pylint-0.26.0.ebuild:
Add ~arm, wrt bug #449220
diff --git a/dev-python/pylint/pylint-0.27.0.ebuild b/dev-python/pylint/pylint-0.27.0.ebuild
new file mode 100644
index 000000000000..fca934f44a6a
--- /dev/null
+++ b/dev-python/pylint/pylint-0.27.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.27.0.ebuild,v 1.1 2013/03/11 06:14:51 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="examples"
+
+# Versions specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0
+ >=dev-python/astng-0.21.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="doc/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.26.0-gtktest.patch
+ distutils_src_prepare
+}
+
+src_test() {
+ testing() {
+ # Test suite broken with Python 3.
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ PYTHONPATH="build/lib" pytest -v
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/pylint/test"
+ }
+ python_execute_function -q delete_tests
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
+}