summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-03-25 09:20:07 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-03-25 09:20:07 +0000
commit07926e5b5866dcd1e7d6c7a2c3c706402c557c29 (patch)
tree2533f2e5227a19e2c0bb53c1550eb3c8feca75b5 /dev-python/pymongo
parentVersion bump (diff)
downloadgentoo-2-07926e5b5866dcd1e7d6c7a2c3c706402c557c29.tar.gz
gentoo-2-07926e5b5866dcd1e7d6c7a2c3c706402c557c29.tar.bz2
gentoo-2-07926e5b5866dcd1e7d6c7a2c3c706402c557c29.zip
Version bump, drop old
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/ChangeLog8
-rw-r--r--dev-python/pymongo/pymongo-2.4.1.ebuild64
-rw-r--r--dev-python/pymongo/pymongo-2.4.2.ebuild64
-rw-r--r--dev-python/pymongo/pymongo-2.4.ebuild64
-rw-r--r--dev-python/pymongo/pymongo-2.5.ebuild129
5 files changed, 136 insertions, 193 deletions
diff --git a/dev-python/pymongo/ChangeLog b/dev-python/pymongo/ChangeLog
index 565d267c4110..2b419d88ba48 100644
--- a/dev-python/pymongo/ChangeLog
+++ b/dev-python/pymongo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pymongo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.19 2013/03/17 18:00:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/ChangeLog,v 1.20 2013/03/25 09:20:07 ultrabug Exp $
+
+*pymongo-2.5 (25 Mar 2013)
+
+ 25 Mar 2013; Ultrabug <ultrabug@gentoo.org> -pymongo-2.4.ebuild,
+ -pymongo-2.4.1.ebuild, -pymongo-2.4.2.ebuild, +pymongo-2.5.ebuild:
+ Version bump, drop old
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-python/pymongo/pymongo-2.4.1.ebuild b/dev-python/pymongo/pymongo-2.4.1.ebuild
deleted file mode 100644
index b21b76aeac5b..000000000000
--- a/dev-python/pymongo/pymongo-2.4.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.4.1.ebuild,v 1.1 2012/12/13 10:22:17 ultrabug Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-inherit distutils
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="http://github.com/mongodb/mongo-python-driver http://pypi.python.org/pypi/pymongo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc mod_wsgi"
-
-RDEPEND="dev-db/mongodb"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="bson gridfs pymongo"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- mkdir html
- sphinx-build doc html || die "Generation of documentation failed"
- fi
-}
-
-distutils_src_test_pre_hook() {
- mkdir -p "${T}/tests-${PYTHON_ABI}/mongo.db"
- mongod --dbpath "${T}/tests-${PYTHON_ABI}/mongo.db" --fork --logpath "${T}/tests-${PYTHON_ABI}/mongo.log"
-}
-
-src_test() {
- distutils_src_test
- killall -u "$(id -nu)" mongod
-}
-
-src_install() {
- # Maintainer note:
- # In order to work with mod_wsgi, we need to disable the C extension.
- # See [1] for more information.
- # [1] http://api.mongodb.org/python/current/faq.html#does-pymongo-work-with-mod-wsgi
- distutils_src_install $(use mod_wsgi && echo --no_ext)
-
- if use doc; then
- dohtml -r html/* || die "Error installing docs"
- fi
-}
-
-pkg_postinst() {
- ewarn "Important changes on this release, make sure to read the changelog:"
- ewarn "http://api.mongodb.org/python/${PV}/changelog.html"
-}
diff --git a/dev-python/pymongo/pymongo-2.4.2.ebuild b/dev-python/pymongo/pymongo-2.4.2.ebuild
deleted file mode 100644
index b08fb7489072..000000000000
--- a/dev-python/pymongo/pymongo-2.4.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.4.2.ebuild,v 1.1 2013/01/25 10:45:44 ultrabug Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-inherit distutils
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="http://github.com/mongodb/mongo-python-driver http://pypi.python.org/pypi/pymongo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc mod_wsgi"
-
-RDEPEND="dev-db/mongodb"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="bson gridfs pymongo"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- mkdir html
- sphinx-build doc html || die "Generation of documentation failed"
- fi
-}
-
-distutils_src_test_pre_hook() {
- mkdir -p "${T}/tests-${PYTHON_ABI}/mongo.db"
- mongod --dbpath "${T}/tests-${PYTHON_ABI}/mongo.db" --fork --logpath "${T}/tests-${PYTHON_ABI}/mongo.log"
-}
-
-src_test() {
- distutils_src_test
- killall -u "$(id -nu)" mongod
-}
-
-src_install() {
- # Maintainer note:
- # In order to work with mod_wsgi, we need to disable the C extension.
- # See [1] for more information.
- # [1] http://api.mongodb.org/python/current/faq.html#does-pymongo-work-with-mod-wsgi
- distutils_src_install $(use mod_wsgi && echo --no_ext)
-
- if use doc; then
- dohtml -r html/* || die "Error installing docs"
- fi
-}
-
-pkg_postinst() {
- ewarn "Important changes on this release, make sure to read the changelog:"
- ewarn "http://api.mongodb.org/python/${PV}/changelog.html"
-}
diff --git a/dev-python/pymongo/pymongo-2.4.ebuild b/dev-python/pymongo/pymongo-2.4.ebuild
deleted file mode 100644
index 370cbd75cb19..000000000000
--- a/dev-python/pymongo/pymongo-2.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.4.ebuild,v 1.2 2012/12/05 04:17:19 mr_bones_ Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-inherit distutils
-
-DESCRIPTION="Python driver for MongoDB"
-HOMEPAGE="http://github.com/mongodb/mongo-python-driver http://pypi.python.org/pypi/pymongo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc mod_wsgi"
-
-RDEPEND="dev-db/mongodb"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="bson gridfs pymongo"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- mkdir html
- sphinx-build doc html || die "Generation of documentation failed"
- fi
-}
-
-distutils_src_test_pre_hook() {
- mkdir -p "${T}/tests-${PYTHON_ABI}/mongo.db"
- mongod --dbpath "${T}/tests-${PYTHON_ABI}/mongo.db" --fork --logpath "${T}/tests-${PYTHON_ABI}/mongo.log"
-}
-
-src_test() {
- distutils_src_test
- killall -u "$(id -nu)" mongod
-}
-
-src_install() {
- # Maintainer note:
- # In order to work with mod_wsgi, we need to disable the C extension.
- # See [1] for more information.
- # [1] http://api.mongodb.org/python/current/faq.html#does-pymongo-work-with-mod-wsgi
- distutils_src_install $(use mod_wsgi && echo --no_ext)
-
- if use doc; then
- dohtml -r html/* || die "Error installing docs"
- fi
-}
-
-pkg_postinst() {
- ewarn "Important changes on this release, make sure to read the changelog:"
- ewarn "http://api.mongodb.org/python/${PV}/changelog.html"
-}
diff --git a/dev-python/pymongo/pymongo-2.5.ebuild b/dev-python/pymongo/pymongo-2.5.ebuild
new file mode 100644
index 000000000000..dabce41b7add
--- /dev/null
+++ b/dev-python/pymongo/pymongo-2.5.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pymongo/pymongo-2.5.ebuild,v 1.1 2013/03/25 09:20:07 ultrabug Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit check-reqs distutils-r1
+
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="http://github.com/mongodb/mongo-python-driver http://pypi.python.org/pypi/pymongo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc kerberos mod_wsgi test"
+
+RDEPEND="dev-db/mongodb"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ kerberos? ( dev-python/pykerberos )"
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir html || die
+ sphinx-build doc html || die
+ fi
+}
+
+src_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27017
+
+ export DB_IP DB_PORT
+
+ # 1.5G of disk space per run.
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --smallfiles --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ nosetests || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}"
+}
+
+python_install() {
+ # Maintainer note:
+ # In order to work with mod_wsgi, we need to disable the C extension.
+ # See [1] for more information.
+ # [1] http://api.mongodb.org/python/current/faq.html#does-pymongo-work-with-mod-wsgi
+ distutils-r1_python_install $(use mod_wsgi && echo --no_ext)
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "Important changes on this release, make sure to read the changelog:"
+ ewarn "http://api.mongodb.org/python/${PV}/changelog.html"
+}