summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-05 08:19:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-05 08:19:49 +0000
commitee92698ab59f9827933d7711306e75e4f26bd806 (patch)
tree66ab359de9aa89b5b2356acf4bcf4b9bf56e5d3a /dev-python/pyopencl
parentUse unmodified 'gtk2hsTypeGen' (bug #512474 by Paweł Hajdan, Jr.). (diff)
downloadgentoo-2-ee92698ab59f9827933d7711306e75e4f26bd806.tar.gz
gentoo-2-ee92698ab59f9827933d7711306e75e4f26bd806.tar.bz2
gentoo-2-ee92698ab59f9827933d7711306e75e4f26bd806.zip
Remove old
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/ChangeLog6
-rw-r--r--dev-python/pyopencl/pyopencl-2011.2-r1.ebuild65
-rw-r--r--dev-python/pyopencl/pyopencl-2012.1.ebuild65
-rw-r--r--dev-python/pyopencl/pyopencl-2013.1.ebuild65
4 files changed, 5 insertions, 196 deletions
diff --git a/dev-python/pyopencl/ChangeLog b/dev-python/pyopencl/ChangeLog
index f1c01b8119ec..9e9f3746327c 100644
--- a/dev-python/pyopencl/ChangeLog
+++ b/dev-python/pyopencl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyopencl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.25 2014/06/05 08:14:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.26 2014/06/05 08:19:49 patrick Exp $
+
+ 05 Jun 2014; Patrick Lauer <patrick@gentoo.org> -pyopencl-2011.2-r1.ebuild,
+ -pyopencl-2012.1.ebuild, -pyopencl-2013.1.ebuild:
+ Remove old
*pyopencl-2014.1 (05 Jun 2014)
diff --git a/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild b/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
deleted file mode 100644
index 04724af1c2ea..000000000000
--- a/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild,v 1.6 2012/04/19 07:32:38 xarthisius Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python]
- dev-python/decorator
- dev-python/numpy
- dev-python/mako
- dev-python/pytools
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_configure()
-{
- configuration() {
- local myconf=()
-
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "$(PYTHON)" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install()
-{
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}
diff --git a/dev-python/pyopencl/pyopencl-2012.1.ebuild b/dev-python/pyopencl/pyopencl-2012.1.ebuild
deleted file mode 100644
index f83fe3bd65fc..000000000000
--- a/dev-python/pyopencl/pyopencl-2012.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2012.1.ebuild,v 1.1 2012/06/28 07:20:28 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python]
- dev-python/decorator
- dev-python/numpy
- dev-python/mako
- dev-python/pytools
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_configure()
-{
- configuration() {
- local myconf=()
-
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "$(PYTHON)" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install()
-{
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}
diff --git a/dev-python/pyopencl/pyopencl-2013.1.ebuild b/dev-python/pyopencl/pyopencl-2013.1.ebuild
deleted file mode 100644
index f990104d5347..000000000000
--- a/dev-python/pyopencl/pyopencl-2013.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2013.1.ebuild,v 1.1 2013/07/08 05:13:15 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python]
- dev-python/decorator
- dev-python/numpy
- dev-python/mako
- dev-python/pytools
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-
-src_configure()
-{
- configuration() {
- local myconf=()
-
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "$(PYTHON)" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-src_install()
-{
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-pkg_postinst()
-{
- distutils_pkg_postinst
- if use examples; then
- elog "Some of the examples provided by this package require dev-python/matplotlib."
- fi
-}