summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-13 07:51:11 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-13 07:51:11 +0000
commit44fc00c3890bc4f2d8c5cbca4e7955ae4560b860 (patch)
tree0bc3edf20597e3883667c13f2ba6b241f940a16c /dev-python/pyquery/pyquery-1.0.ebuild
parentlibnss-mysql: install location back to /usr, because it needs to be on the sa... (diff)
downloadgentoo-2-44fc00c3890bc4f2d8c5cbca4e7955ae4560b860.tar.gz
gentoo-2-44fc00c3890bc4f2d8c5cbca4e7955ae4560b860.tar.bz2
gentoo-2-44fc00c3890bc4f2d8c5cbca4e7955ae4560b860.zip
Version bump pyquery to 1.0.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyquery/pyquery-1.0.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyquery/pyquery-1.0.ebuild b/dev-python/pyquery/pyquery-1.0.ebuild
new file mode 100644
index 000000000000..391929764bbd
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/pyquery-1.0.ebuild,v 1.1 2011/09/13 07:51:11 djc Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+#DISTUTILS_SRC_TEST="nosetests" somewhat works, tries to test docs
+
+inherit distutils
+
+DESCRIPTION="A jquery-like library for python"
+HOMEPAGE="http://pypi.python.org/pypi/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/lxml-2.1"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/webob
+ dev-python/nose
+ )"
+
+DOCS="CHANGES.txt"