summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-03-04 20:42:51 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-03-04 20:42:51 +0000
commit90b92f987734569f2d80ba9fd02a44e0c249e97b (patch)
tree8aa0fabff4e99e7fa326327bf5a1d53429911f89 /dev-python/pyrax
parentinitial add of pyrax (diff)
downloadgentoo-2-90b92f987734569f2d80ba9fd02a44e0c249e97b.tar.gz
gentoo-2-90b92f987734569f2d80ba9fd02a44e0c249e97b.tar.bz2
gentoo-2-90b92f987734569f2d80ba9fd02a44e0c249e97b.zip
pyrax-1.3.1 fast follow thingy
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pyrax')
-rw-r--r--dev-python/pyrax/ChangeLog7
-rw-r--r--dev-python/pyrax/pyrax-1.3.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/pyrax/ChangeLog b/dev-python/pyrax/ChangeLog
index 43b25cf9003d..07167ebc0e3c 100644
--- a/dev-python/pyrax/ChangeLog
+++ b/dev-python/pyrax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyrax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.1 2013/03/04 20:37:29 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.2 2013/03/04 20:42:51 prometheanfire Exp $
+
+*pyrax-1.3.1 (04 Mar 2013)
+
+ 04 Mar 2013; Matthew Thode <prometheanfire@gentoo.org> +pyrax-1.3.1.ebuild:
+ pyrax-1.3.1 fast follow thingy
*pyrax-9999 (04 Mar 2013)
*pyrax-1.3.0 (04 Mar 2013)
diff --git a/dev-python/pyrax/pyrax-1.3.1.ebuild b/dev-python/pyrax/pyrax-1.3.1.ebuild
new file mode 100644
index 000000000000..ff8a34f85897
--- /dev/null
+++ b/dev-python/pyrax/pyrax-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/pyrax-1.3.1.ebuild,v 1.1 2013/03/04 20:42:51 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python SDK for OpenStack/Rackspace APIs"
+HOMEPAGE="https://github.com/openstack/python-novaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock
+ >=dev-python/python-novaclient-2.10.0[${PYTHON_USEDEP}]
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/prettytable
+ >=dev-python/python-novaclient-2.10.0[${PYTHON_USEDEP}]
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}