summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-02-14 11:59:31 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-02-14 11:59:31 +0000
commita33e9f678295f169b6e886307c161825c945b905 (patch)
tree397159149dec7fa4562e7bbfa5b443341b6bf5a5 /dev-python/pysrt
parentStable for amd64 wrt bug #500036 (diff)
downloadgentoo-2-a33e9f678295f169b6e886307c161825c945b905.tar.gz
gentoo-2-a33e9f678295f169b6e886307c161825c945b905.tar.bz2
gentoo-2-a33e9f678295f169b6e886307c161825c945b905.zip
Bump to 1.0.1, thanks to Nikoli
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/ChangeLog8
-rw-r--r--dev-python/pysrt/pysrt-1.0.1.ebuild38
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild4
3 files changed, 47 insertions, 3 deletions
diff --git a/dev-python/pysrt/ChangeLog b/dev-python/pysrt/ChangeLog
index 166ce07d6710..187635eac289 100644
--- a/dev-python/pysrt/ChangeLog
+++ b/dev-python/pysrt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysrt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysrt/ChangeLog,v 1.2 2014/01/16 12:00:38 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysrt/ChangeLog,v 1.3 2014/02/14 11:59:31 maksbotan Exp $
+
+*pysrt-1.0.1 (14 Feb 2014)
+
+ 14 Feb 2014; Maxim Koltsov <maksbotan@gentoo.org> +pysrt-1.0.1.ebuild,
+ pysrt-9999.ebuild:
+ Bump to 1.0.1, thanks to Nikoli
*pysrt-1.0.0 (16 Jan 2014)
diff --git a/dev-python/pysrt/pysrt-1.0.1.ebuild b/dev-python/pysrt/pysrt-1.0.1.ebuild
new file mode 100644
index 000000000000..89b190908209
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysrt/pysrt-1.0.1.ebuild,v 1.1 2014/02/14 11:59:31 maksbotan Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+# https://github.com/byroot/pysrt/issues/42
+RESTRICT="test"
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index d5098e7b97e3..1ed8935ec2c0 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysrt/pysrt-9999.ebuild,v 1.2 2014/01/16 12:00:38 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysrt/pysrt-9999.ebuild,v 1.3 2014/02/14 11:59:31 maksbotan Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -17,7 +17,7 @@ KEYWORDS=""
IUSE="test"
RDEPEND="
- dev-python/charade[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}