summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-06 23:09:26 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-06 23:09:26 +0000
commit789fe84604f0322b34baab4bddfe7c30fa3eec54 (patch)
treee84c860be6458a172062bd18542460075922bc1b /dev-python/pytest-runner
parentVersion bump #450642 by Agostino Sarubbo. (diff)
downloadgentoo-2-789fe84604f0322b34baab4bddfe7c30fa3eec54.tar.gz
gentoo-2-789fe84604f0322b34baab4bddfe7c30fa3eec54.tar.bz2
gentoo-2-789fe84604f0322b34baab4bddfe7c30fa3eec54.zip
Clean up the ebuild. Migrate to distutils-r1. Add Python team as a co-maintainer.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pytest-runner')
-rw-r--r--dev-python/pytest-runner/ChangeLog12
-rw-r--r--dev-python/pytest-runner/metadata.xml23
-rw-r--r--dev-python/pytest-runner/pytest-runner-1.1-r1.ebuild26
3 files changed, 47 insertions, 14 deletions
diff --git a/dev-python/pytest-runner/ChangeLog b/dev-python/pytest-runner/ChangeLog
index ca42be6a7ad3..2d65a1bf7836 100644
--- a/dev-python/pytest-runner/ChangeLog
+++ b/dev-python/pytest-runner/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pytest-runner
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-runner/ChangeLog,v 1.2 2012/12/28 06:06:22 prometheanfire Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-runner/ChangeLog,v 1.3 2013/01/06 23:09:26 mgorny Exp $
+
+*pytest-runner-1.1-r1 (06 Jan 2013)
+
+ 06 Jan 2013; Michał Górny <mgorny@gentoo.org> +pytest-runner-1.1-r1.ebuild,
+ metadata.xml:
+ Clean up the ebuild. Migrate to distutils-r1. Add Python team as a co-
+ maintainer.
28 Dec 2012; Matthew Thode <prometheanfire@gentoo.org>
+files/pytest-runner-1.1_setup.patch:
@@ -11,4 +18,3 @@
28 Dec 2012; Matthew Thode <prometheanfire@gentoo.org>
+pytest-runner-1.1.ebuild, +metadata.xml:
initial add of pytest-runner (needed for dev-python/keyring)
-
diff --git a/dev-python/pytest-runner/metadata.xml b/dev-python/pytest-runner/metadata.xml
index e00688e6e438..f0eec1657131 100644
--- a/dev-python/pytest-runner/metadata.xml
+++ b/dev-python/pytest-runner/metadata.xml
@@ -1,11 +1,12 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <longdescription lang="en">
- Adds support for tests durring installation of setup.py files.
- </longdescription>
-</pkgmetadata>
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Adds support for tests during installation of setup.py files.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-runner/pytest-runner-1.1-r1.ebuild b/dev-python/pytest-runner/pytest-runner-1.1-r1.ebuild
new file mode 100644
index 000000000000..0357a1beb2ad
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-1.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-runner/pytest-runner-1.1-r1.ebuild,v 1.1 2013/01/06 23:09:26 mgorny Exp $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests durring installation of setup.py files."
+HOMEPAGE="http://pypi.python.org/pypi/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/hgtools[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/pytest-runner.patch"
+)