summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-11-18 21:43:46 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-11-18 21:43:46 +0000
commita56686278c0fb8d4ca57043ba028e35f5e0068d3 (patch)
tree544ab544165c9598fcbf8cc388c010a9842b7a4b /dev-python/python-cinderclient
parentbup (diff)
downloadgentoo-2-a56686278c0fb8d4ca57043ba028e35f5e0068d3.tar.gz
gentoo-2-a56686278c0fb8d4ca57043ba028e35f5e0068d3.tar.bz2
gentoo-2-a56686278c0fb8d4ca57043ba028e35f5e0068d3.zip
bup
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/ChangeLog8
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.1.1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/python-cinderclient/ChangeLog b/dev-python/python-cinderclient/ChangeLog
index bacf7f1e45f6..1e314c02a9c8 100644
--- a/dev-python/python-cinderclient/ChangeLog
+++ b/dev-python/python-cinderclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-cinderclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.12 2014/08/01 05:50:51 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/ChangeLog,v 1.13 2014/11/18 21:43:46 prometheanfire Exp $
+
+*python-cinderclient-1.1.1 (18 Nov 2014)
+
+ 18 Nov 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-cinderclient-1.1.1.ebuild:
+ bup
01 Aug 2014; Matthew Thode <prometheanfire@gentoo.org>
-python-cinderclient-1.0.7.ebuild:
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.1.1.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.1.1.ebuild
new file mode 100644
index 000000000000..b1ea017d4a4e
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-1.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-cinderclient/python-cinderclient-1.1.1.ebuild,v 1.1 2014/11/18 21:43:46 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ )"
+RDEPEND=">=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run --parallel || die "tests failed under python2.7"
+ flake8 cinderclient/tests || die "run by flake8 over tests folder yielded error"
+}