summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-01-05 00:33:28 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-01-05 00:33:28 +0000
commitc088037eea89dd0d6599ec7dc98c4e654c251be9 (patch)
treef79fc5f5031a53b5ec4b2bd3d6f1f4a1256b33af /dev-python/python-docs/python-docs-2.4.ebuild
parent~amd64 keyword added (Manifest recommit) (diff)
downloadgentoo-2-c088037eea89dd0d6599ec7dc98c4e654c251be9.tar.gz
gentoo-2-c088037eea89dd0d6599ec7dc98c4e654c251be9.tar.bz2
gentoo-2-c088037eea89dd0d6599ec7dc98c4e654c251be9.zip
Version bump.
Diffstat (limited to 'dev-python/python-docs/python-docs-2.4.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.4.ebuild b/dev-python/python-docs/python-docs-2.4.ebuild
new file mode 100644
index 000000000000..1fc297a70ed7
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.4.ebuild,v 1.1 2005/01/05 00:33:28 pythonhead Exp $
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/2.4/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ docinto html
+ cp -R ${S}/Python-Docs-${PV}/* ${D}/usr/share/doc/${PF}/html
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html" > ${D}/etc/env.d/50python-docs
+}