summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-19 10:31:48 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-19 10:31:48 +0000
commit2ebd6c7080fc57592e04d0e94a610262e24ad30e (patch)
treeceddde6e1a29f1d0d17b78eb237911dd2a80d164 /dev-python/python-geoclue
parentmedia-libs/sg: Always build complete X support, #421807 (diff)
downloadgentoo-2-2ebd6c7080fc57592e04d0e94a610262e24ad30e.tar.gz
gentoo-2-2ebd6c7080fc57592e04d0e94a610262e24ad30e.tar.bz2
gentoo-2-2ebd6c7080fc57592e04d0e94a610262e24ad30e.zip
dev-python/python-geoclue: Use virtualx for during src_test, #421911
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-geoclue')
-rw-r--r--dev-python/python-geoclue/ChangeLog5
-rw-r--r--dev-python/python-geoclue/python-geoclue-0.1.0.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/python-geoclue/ChangeLog b/dev-python/python-geoclue/ChangeLog
index c70bcecfcc91..216af1bce7d9 100644
--- a/dev-python/python-geoclue/ChangeLog
+++ b/dev-python/python-geoclue/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/python-geoclue
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/ChangeLog,v 1.3 2012/02/24 08:55:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/ChangeLog,v 1.4 2012/06/19 10:31:48 jlec Exp $
+
+ 19 Jun 2012; Justin Lecher <jlec@gentoo.org> python-geoclue-0.1.0.ebuild:
+ Use virtualx for during src_test, #421911
24 Feb 2012; Patrick Lauer <patrick@gentoo.org> python-geoclue-0.1.0.ebuild:
Restricting pypy and jython
diff --git a/dev-python/python-geoclue/python-geoclue-0.1.0.ebuild b/dev-python/python-geoclue/python-geoclue-0.1.0.ebuild
index 0fb272d7aa00..253d5dad7bf6 100644
--- a/dev-python/python-geoclue/python-geoclue-0.1.0.ebuild
+++ b/dev-python/python-geoclue/python-geoclue-0.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/python-geoclue-0.1.0.ebuild,v 1.4 2012/02/24 08:55:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-geoclue/python-geoclue-0.1.0.ebuild,v 1.5 2012/06/19 10:31:48 jlec Exp $
EAPI=4
@@ -9,7 +9,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* 2.5 2.7-pypy-* *-jython"
PYTHON_MODNAME="Geoclue"
-inherit distutils
+inherit distutils virtualx
DESCRIPTION="Geoclue python module"
HOMEPAGE="http://live.gnome.org/gtg/soc/python_geoclue/"
@@ -29,7 +29,8 @@ S="${WORKDIR}"/${PN}
src_test() {
testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/test.py
+ VIRTUALX_COMMAND="$(PYTHON)"
+ PYTHONPATH="build-${PYTHON_ABI}/lib" virtualmake tests/test.py
}
python_execute_function testing
}