summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-08-01 04:51:20 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-08-01 04:51:20 +0000
commit404bf49cb702120798e7fa0cd02277c8d0f05bbe (patch)
tree5befed784acd755be697ec1dc39d6b8412671503 /dev-python/python-glanceclient
parentremoving the old and jankey, adding the new hotness (diff)
downloadgentoo-2-404bf49cb702120798e7fa0cd02277c8d0f05bbe.tar.gz
gentoo-2-404bf49cb702120798e7fa0cd02277c8d0f05bbe.tar.bz2
gentoo-2-404bf49cb702120798e7fa0cd02277c8d0f05bbe.zip
removing the old and jankey, adding the new hotness
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/ChangeLog8
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.13.1.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/python-glanceclient/ChangeLog b/dev-python/python-glanceclient/ChangeLog
index c23677c3c3a8..5c915e936350 100644
--- a/dev-python/python-glanceclient/ChangeLog
+++ b/dev-python/python-glanceclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-glanceclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.11 2014/07/06 12:47:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.12 2014/08/01 04:51:20 prometheanfire Exp $
+
+*python-glanceclient-0.13.1 (01 Aug 2014)
+
+ 01 Aug 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-glanceclient-0.13.1.ebuild:
+ removing the old and jankey, adding the new hotness
06 Jul 2014; Michał Górny <mgorny@gentoo.org>
python-glanceclient-0.12.0.ebuild:
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.13.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.13.1.ebuild
new file mode 100644
index 000000000000..b9ace7f341a7
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-0.13.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.13.1.ebuild,v 1.1 2014/08/01 04:51:20 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="test? ( doc )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=">=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ !~dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.11[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.0.1[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}