summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-01 08:39:20 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-01 08:39:20 +0000
commit00509b0eff381407a49e5020d443079cefe7d049 (patch)
tree669a692a52ad41b673814b1e8f2ce770a9e7813e /dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
parentStable for arm, wrt bug #419909 (diff)
downloadgentoo-2-00509b0eff381407a49e5020d443079cefe7d049.tar.gz
gentoo-2-00509b0eff381407a49e5020d443079cefe7d049.tar.bz2
gentoo-2-00509b0eff381407a49e5020d443079cefe7d049.zip
initial commit of python-keystoneclient
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild')
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
new file mode 100644
index 000000000000..953db5721b1a
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-9999.ebuild,v 1.1 2013/01/01 08:39:20 prometheanfire Exp $
+
+EAPI=5
+#restricted due to packages missing and bad depends in the test ==webob-1.0.8
+RESTRICT="test"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit git-2 distutils-r1
+
+DESCRIPTION="A client for the OpenStack Keystone API."
+HOMEPAGE="https://github.com/openstack/python-keystoneclient"
+EGIT_REPO_URI="https://github.com/openstack/python-keystoneclient.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+#IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/httplib2
+ dev-python/prettytable
+ dev-python/requests
+ dev-python/simplejson
+ virtual/python-argparse"
+# test? ( dev-python/Babel
+# dev-python/coverage
+# dev-python/iso8601
+# dev-python/keyring
+# dev-python/mock
+# dev-python/mox
+# dev-python/nose
+# dev-python/nose-exclude #not packaged
+# dev-python/nosehtmloutput #not packaged
+# >=dev-python/pep8-1.3.3
+# >=app-misc/sphinx-1.1.2
+# dev-python/unittest2
+# >=dev-python/webob-1.0.8 )"
+#
+#python_test() {
+# "${PYTHON} setup.py nosetests || die
+#}