summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-06 00:15:26 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-06 00:15:26 +0000
commit526772903f231d6ce72a9e987d7711b9913c8dfc (patch)
tree5521af357e9484eb93941546da8d4dbea1cd7782 /dev-python/python-oembed
parentProxy commit for Johan Bergström. Version bump. (diff)
downloadgentoo-2-526772903f231d6ce72a9e987d7711b9913c8dfc.tar.gz
gentoo-2-526772903f231d6ce72a9e987d7711b9913c8dfc.tar.bz2
gentoo-2-526772903f231d6ce72a9e987d7711b9913c8dfc.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-oembed')
-rw-r--r--dev-python/python-oembed/ChangeLog10
-rw-r--r--dev-python/python-oembed/python-oembed-0.2.1-r1.ebuild (renamed from dev-python/python-oembed/python-oembed-0.2.1.ebuild)22
2 files changed, 20 insertions, 12 deletions
diff --git a/dev-python/python-oembed/ChangeLog b/dev-python/python-oembed/ChangeLog
index 20aafb32a652..63f2c6adec26 100644
--- a/dev-python/python-oembed/ChangeLog
+++ b/dev-python/python-oembed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-oembed
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-oembed/ChangeLog,v 1.2 2014/08/10 21:19:20 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-oembed/ChangeLog,v 1.3 2015/01/06 00:15:26 idella4 Exp $
+
+*python-oembed-0.2.1-r1 (06 Jan 2015)
+
+ 06 Jan 2015; Ian Delaney <idella4@gentoo.org> +python-oembed-0.2.1-r1.ebuild,
+ -python-oembed-0.2.1.ebuild:
+ revbump; conversion -> distutils-r1, rm old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
python-oembed-0.2.1.ebuild:
diff --git a/dev-python/python-oembed/python-oembed-0.2.1.ebuild b/dev-python/python-oembed/python-oembed-0.2.1-r1.ebuild
index b60db26b034c..c153136e321e 100644
--- a/dev-python/python-oembed/python-oembed-0.2.1.ebuild
+++ b/dev-python/python-oembed/python-oembed-0.2.1-r1.ebuild
@@ -1,14 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-oembed/python-oembed-0.2.1.ebuild,v 1.2 2014/08/10 21:19:20 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-oembed/python-oembed-0.2.1-r1.ebuild,v 1.1 2015/01/06 00:15:26 idella4 Exp $
-EAPI=4
-DISTUTILS_SRC_TEST="nosetests"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2"
-RESTRICT_PYTHON_ABIS="3.*"
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="A Python library that implements an OEmbed consumer"
HOMEPAGE="http://pypi.python.org/pypi/python-oembed"
@@ -19,5 +16,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed"
+}