summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-26 09:47:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-26 09:47:01 +0000
commitcd9b9c47d960f331a6ad87d26010cfbce7bc6686 (patch)
treea49c1b458e3083da7806dc529918f36ceddcda04 /dev-python/python-openid
parentAdd ~arm keyword, wrt bug #458248 (diff)
downloadgentoo-2-cd9b9c47d960f331a6ad87d26010cfbce7bc6686.tar.gz
gentoo-2-cd9b9c47d960f331a6ad87d26010cfbce7bc6686.tar.bz2
gentoo-2-cd9b9c47d960f331a6ad87d26010cfbce7bc6686.zip
Adding test deps #458252
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/ChangeLog6
-rw-r--r--dev-python/python-openid/python-openid-2.2.5-r1.ebuild54
-rw-r--r--dev-python/python-openid/python-openid-2.2.5.ebuild10
3 files changed, 11 insertions, 59 deletions
diff --git a/dev-python/python-openid/ChangeLog b/dev-python/python-openid/ChangeLog
index b6c55f2936b1..d8f292974e92 100644
--- a/dev-python/python-openid/ChangeLog
+++ b/dev-python/python-openid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-openid
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.19 2013/02/12 13:15:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.20 2013/03/26 09:47:01 patrick Exp $
+
+ 26 Mar 2013; Patrick Lauer <patrick@gentoo.org>
+ -python-openid-2.2.5-r1.ebuild, python-openid-2.2.5.ebuild:
+ Adding test deps #458252
*python-openid-2.2.5-r1 (12 Feb 2013)
diff --git a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild b/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
deleted file mode 100644
index 49e3b6b2165b..000000000000
--- a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.5-r1.ebuild,v 1.1 2013/02/12 13:15:19 mgorny Exp $
-
-EAPI=5
-
-PYTHON_REQ_USE='sqlite?'
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="OpenID support for servers and consumers."
-HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/ http://pypi.python.org/pypi/python-openid"
-# Downloaded from http://github.com/openid/python-openid/downloads
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="examples mysql postgres sqlite"
-
-RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/openid-python-openid-b666238"
-
-python_prepare_all() {
- local PATCHES=(
- # Patch to fix confusion with localhost/127.0.0.1
- "${FILESDIR}/${PN}-2.0.0-gentoo-test_fetchers.diff"
- )
-
- # Disable broken tests from from examples/djopenid.
- # Remove test that requires running db server.
- sed -e "s/django_failures =.*/django_failures = 0/" \
- -e '/storetest/d' \
- -i admin/runtests || die "sed admin/runtests failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" admin/runtests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/python-openid/python-openid-2.2.5.ebuild b/dev-python/python-openid/python-openid-2.2.5.ebuild
index b32a37592b94..e280d264466c 100644
--- a/dev-python/python-openid/python-openid-2.2.5.ebuild
+++ b/dev-python/python-openid/python-openid-2.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.5.ebuild,v 1.5 2011/05/24 21:02:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.5.ebuild,v 1.6 2013/03/26 09:47:01 patrick Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -17,12 +17,14 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="examples mysql postgres sqlite"
+IUSE="examples mysql postgres sqlite test"
RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2 )
postgres? ( dev-python/psycopg )
sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/twill
+ dev-python/pycurl )"
S="${WORKDIR}/openid-python-openid-b666238"