summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-13 03:08:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-13 03:08:20 +0000
commit30576da28f3732a0ae31d4a05053fba8bee09480 (patch)
treeb3ae836e26a2cab07efe844b205c530c86c58f9c /dev-python/python-ptrace
parentBump (diff)
downloadgentoo-2-30576da28f3732a0ae31d4a05053fba8bee09480.tar.gz
gentoo-2-30576da28f3732a0ae31d4a05053fba8bee09480.tar.bz2
gentoo-2-30576da28f3732a0ae31d4a05053fba8bee09480.zip
Bump
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog10
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.5.ebuild45
2 files changed, 52 insertions, 3 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index 91c9c3654f4e..eefa4c6fc6ab 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ptrace
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.10 2012/03/09 09:24:15 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.11 2013/06/13 03:08:20 patrick Exp $
+
+*python-ptrace-0.6.5 (13 Jun 2013)
+
+ 13 Jun 2013; Patrick Lauer <patrick@gentoo.org> +python-ptrace-0.6.5.ebuild:
+ Bump
*python-ptrace-0.6.4 (09 Mar 2012)
@@ -49,4 +54,3 @@
03 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+python-ptrace-0.5.ebuild:
Initial import. Ebuild from Tuna <tuna@lyua.org>. Closes #247892
-
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild
new file mode 100644
index 000000000000..c7c841dda737
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.5.ebuild,v 1.1 2013/06/13 03:08:20 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-libs/distorm64"
+RESTRICT_PYTHON_ABIS="2.4"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="ptrace"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
+ 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}