summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-01 09:13:07 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-01 09:13:07 +0000
commit50b08ac6faeeda4df3e1cc418453f916ab2d92c9 (patch)
tree6b231145cd74c9711a40923b989f6bc0c110823e /dev-python/pythondialog
parentStable for all wrt bug #496422; Drop old. (diff)
downloadgentoo-2-50b08ac6faeeda4df3e1cc418453f916ab2d92c9.tar.gz
gentoo-2-50b08ac6faeeda4df3e1cc418453f916ab2d92c9.tar.bz2
gentoo-2-50b08ac6faeeda4df3e1cc418453f916ab2d92c9.zip
bump; add py3.4 suppot, IUSE examples and its install, remove one old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pythondialog')
-rw-r--r--dev-python/pythondialog/ChangeLog8
-rw-r--r--dev-python/pythondialog/pythondialog-3.1.0.ebuild (renamed from dev-python/pythondialog/pythondialog-2.7-r1.ebuild)14
2 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/pythondialog/ChangeLog b/dev-python/pythondialog/ChangeLog
index 580ea1e9d4e9..a6b4517343f7 100644
--- a/dev-python/pythondialog/ChangeLog
+++ b/dev-python/pythondialog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pythondialog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.19 2014/08/10 21:20:11 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.20 2014/09/01 09:13:07 idella4 Exp $
+
+*pythondialog-3.1.0 (01 Sep 2014)
+
+ 01 Sep 2014; Ian Delaney <idella4@gentoo.org> +pythondialog-3.1.0.ebuild,
+ -pythondialog-2.7-r1.ebuild:
+ bump; add py3.4 suppot, IUSE examples and its install, remove one old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
pythondialog-2.7-r1.ebuild, pythondialog-2.7.ebuild,
diff --git a/dev-python/pythondialog/pythondialog-2.7-r1.ebuild b/dev-python/pythondialog/pythondialog-3.1.0.ebuild
index 20715920acf9..d02150b7faa4 100644
--- a/dev-python/pythondialog/pythondialog-2.7-r1.ebuild
+++ b/dev-python/pythondialog/pythondialog-3.1.0.ebuild
@@ -1,25 +1,25 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-2.7-r1.ebuild,v 1.2 2014/08/10 21:20:11 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-3.1.0.ebuild,v 1.1 2014/09/01 09:13:07 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python{3_2,3_3,3_4} )
inherit distutils-r1
DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
HOMEPAGE="http://pythondialog.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pythondialog/${P}.tar.bz2"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE=""
+IUSE="examples"
DEPEND="dev-util/dialog"
RDEPEND="${DEPEND}"
-python_prepare_all() {
- sed -e "/^prefix=/d" -i setup.cfg || die "sed failed"
- distutils-r1_python_prepare_all
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
}