summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-03 23:09:50 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-03 23:09:50 +0000
commit43462515445150eac3b2f6d69dca613ac27a4979 (patch)
tree66a9e725fde47cadcbe8154b72c80eaedf1ef431 /dev-python/pyxattr
parentAdd support for using yenc (diff)
downloadgentoo-2-43462515445150eac3b2f6d69dca613ac27a4979.tar.gz
gentoo-2-43462515445150eac3b2f6d69dca613ac27a4979.tar.bz2
gentoo-2-43462515445150eac3b2f6d69dca613ac27a4979.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/ChangeLog7
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/pyxattr/ChangeLog b/dev-python/pyxattr/ChangeLog
index cd24f58a4698..b4ecc5a5d794 100644
--- a/dev-python/pyxattr/ChangeLog
+++ b/dev-python/pyxattr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyxattr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.43 2013/01/03 21:29:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.44 2013/01/03 23:09:50 mgorny Exp $
+
+*pyxattr-0.5.2 (03 Jan 2013)
+
+ 03 Jan 2013; Michał Górny <mgorny@gentoo.org> +pyxattr-0.5.2.ebuild:
+ Version bump.
*pyxattr-9999 (03 Jan 2013)
diff --git a/dev-python/pyxattr/pyxattr-0.5.2.ebuild b/dev-python/pyxattr/pyxattr-0.5.2.ebuild
new file mode 100644
index 000000000000..4f6c4780e82e
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.2.ebuild,v 1.1 2013/01/03 23:09:50 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ http://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}