summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-21 20:59:42 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-21 20:59:42 +0000
commit6abbee45977f7fa8b0b1dd648b15c917215e88af (patch)
tree9e2154b2734d24cc2edddf0ba9559db1eade2361 /dev-python/pyxattr
parentFix license, add missing etrophy dependency (diff)
downloadgentoo-2-6abbee45977f7fa8b0b1dd648b15c917215e88af.tar.gz
gentoo-2-6abbee45977f7fa8b0b1dd648b15c917215e88af.tar.bz2
gentoo-2-6abbee45977f7fa8b0b1dd648b15c917215e88af.zip
Version bump, resolves bug 448082. Drop python2.5 from 0.5.0 again.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/ChangeLog8
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild4
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.1.ebuild35
3 files changed, 44 insertions, 3 deletions
diff --git a/dev-python/pyxattr/ChangeLog b/dev-python/pyxattr/ChangeLog
index 3d078cef5341..742c0c02a215 100644
--- a/dev-python/pyxattr/ChangeLog
+++ b/dev-python/pyxattr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyxattr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.36 2012/12/21 18:03:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.37 2012/12/21 20:59:42 floppym Exp $
+
+*pyxattr-0.5.1 (21 Dec 2012)
+
+ 21 Dec 2012; Mike Gilbert <floppym@gentoo.org> +pyxattr-0.5.1.ebuild,
+ pyxattr-0.5.0-r1.ebuild:
+ Version bump, resolves bug 448082. Drop python2.5 from 0.5.0 again.
21 Dec 2012; Mike Gilbert <floppym@gentoo.org> pyxattr-0.5.0-r1.ebuild,
pyxattr-0.5.0.ebuild:
diff --git a/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild b/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild
index 7df81bb05528..1cb018c9ecda 100644
--- a/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild
+++ b/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild,v 1.3 2012/12/21 18:03:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild,v 1.4 2012/12/21 20:59:42 floppym Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1} )
inherit distutils-r1
diff --git a/dev-python/pyxattr/pyxattr-0.5.1.ebuild b/dev-python/pyxattr/pyxattr-0.5.1.ebuild
new file mode 100644
index 000000000000..fc0b2e572205
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.1.ebuild,v 1.1 2012/12/21 20:59:42 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}