summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-07-10 12:31:55 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-07-10 12:31:55 +0000
commitd21e4e6cc33df6460482be8b9d79e4b292860939 (patch)
treef05ae2af5111902ef5e9ddcc63a1936ac14dce6c /dev-python/pyyaml
parentalpha/ia64/s390/sh/sparc stable wrt #374001 (diff)
downloadgentoo-2-d21e4e6cc33df6460482be8b9d79e4b292860939.tar.gz
gentoo-2-d21e4e6cc33df6460482be8b9d79e4b292860939.tar.bz2
gentoo-2-d21e4e6cc33df6460482be8b9d79e4b292860939.zip
version bump. new version supports python 3.2. solving bug #318925.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/ChangeLog9
-rw-r--r--dev-python/pyyaml/pyyaml-3.10.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-python/pyyaml/ChangeLog b/dev-python/pyyaml/ChangeLog
index 6b102e9e2c26..f9ab3581a34e 100644
--- a/dev-python/pyyaml/ChangeLog
+++ b/dev-python/pyyaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyyaml
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyyaml/ChangeLog,v 1.22 2010/09/30 09:06:43 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyyaml/ChangeLog,v 1.23 2011/07/10 12:31:55 sbriesen Exp $
+
+*pyyaml-3.10 (10 Jul 2011)
+
+ 10 Jul 2011; Stefan Briesenick <sbriesen@gentoo.org> +pyyaml-3.10.ebuild:
+ version bump. new version supports python 3.2. solving bug #318925.
30 Sep 2010; Fabian Groffen <grobian@gentoo.org> pyyaml-3.09.ebuild:
Marked ~ppc-macos, ~x86-solaris
diff --git a/dev-python/pyyaml/pyyaml-3.10.ebuild b/dev-python/pyyaml/pyyaml-3.10.ebuild
new file mode 100644
index 000000000000..d55bb2c5c699
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyyaml/pyyaml-3.10.ebuild,v 1.1 2011/07/10 12:31:55 sbriesen Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="http://pyyaml.org/wiki/PyYAML http://pypi.python.org/pypi/PyYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="examples libyaml"
+
+DEPEND="libyaml? ( dev-libs/libyaml dev-python/pyrex )"
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+RESTRICT_PYTHON_ABIS="2.4"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="yaml"
+
+pkg_setup() {
+ DISTUTILS_GLOBAL_OPTIONS=($(use_with libyaml))
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/.
+ fi
+}